User Tag List

Page 2 of 2 FirstFirst 12
Results 41 to 67 of 67

Thread: [Free] Simple Road Tool

  1. #41
    0
    Hi, great tool
    ... but, is that workling with UE 4.15.1.? Because when I click on "AddEnd - Run" button in Blubility panel, nothing happened (it will not create another paths). Maybe I miss something.

    In video is this step on 2:16
    https://www.youtube.com/watch?v=31SIyEPOen4

    Thanks for help

  2. #42
    0
    Hi people,
    Sorry that I forgot a little bit about this tool, I had some exams etc. -> Not much time to do anything. So I start with answering some questions.

    Quote Originally Posted by xBULL3TxSP0NGEx View Post
    I haven't downloaded this yet, plan to this week, but is the tool with meshes and textures already implemented and functioning just as seen in the video available for purchase on CGTRADER? I looked but didn't see it on your page.
    I can put the pieces for sale on CGTrader. But I will have to change the textures a bit because I don't own the textures I used (they are from CGTextures ).

    Quote Originally Posted by Sitrec View Post
    Thanks for sharing this. Do you have any plans for continued development of this? I hope this could be a replacement for the paid Road Tool plugin as it seems to have been abandoned. I would gladly pay for this if you decide to continue develop it.
    At the moment its a bit problematic for me to develop further. The Editor currently suffers from heavy bugs on Linux (which I am using). For instance it crashes when opening skeletal meshes or the Engine-Settings. I already filed some bug reports and hope that it gets better
    However, the tool will remain free. I think its a nice small edition many people could need. As specially starters. Thats why the way is free and "open-source".

    Quote Originally Posted by Kamran Wajdani View Post
    From Where i can download this blueprint i am unable to find download link and attached file link is just blank text: http://prntscr.com/ephsfl
    Sorry that seams like a bug within Epics forum. I uploaded the files to their forum. Maybe try again later?

    Quote Originally Posted by Adnoh View Post
    Thank you. One thing I'm missing while testing - U use the "MarkingMesh" for displaying the Landscape Marks. Which one can/should we use for that? Can you provide yours?
    Can you explain a little about the landscape feature - I don't get it working at all (except for getting the heightmap adjusted to my road) - but how to use the other landscape parameters.
    => ok figgured out you need to fill in the makeArray in your LandscapeTransform Funtion. Works - but chance is really high to F+Up your hole Landscape Saving a lot is your friend.
    While playing around I get it nearly always messed up everything when using "Align to surface" and need to reload the complete map to fix it.

    Is it ok four you if I "fork" this one? I'd like to work on some parts, cleanup the BP, and add things like Road Bend/Roll and Width. Do you still continue workin gon this? Than I'd put my version in a post of this thread, if not I'd create a new forum thread and link to this one if your fine with that.
    You are free to fork it and make improvements. If you want you can post the improvements/blueprint here. I would add the to the main thread post so everyone can see them. However as I mentioned above I won't work on this in the next few weeks.
    [EDIT] I forgot to answer the thing with the landscape
    Yes its right. The landscape feature is already build in the blueprint editor. Sadly as you also found out a little bit buggy. But I can't do anything against it as far as I know.
    For the mesh I use a 1x1 plane with a grid texture on it. You can activate it and it should show you now the area in which the landscape-alignment influences. There are actually two an "inner" one where the influence starts and an "outer" one in which it ends (for smooth transition between road and landscape of cause ).
    Last edited by siebencorgie; 04-17-2017 at 01:26 PM. Reason: added info

  3. #43
    0
    Quote Originally Posted by Michal Deak View Post
    Hi, great tool
    ... but, is that workling with UE 4.15.1.? Because when I click on "AddEnd - Run" button in Blubility panel, nothing happened (it will not create another paths). Maybe I miss something.

    In video is this step on 2:16
    https://www.youtube.com/watch?v=31SIyEPOen4

    Thanks for help
    Hi,
    did you add sockets for the mesh. If not double click your mesh and add some sockets within the socket manager (i guess somewhere in the bottom right) with the appropriate location and roation (the red arrow should point "out" of your street towards the "to be connected" road).

  4. #44
    0
    Quote Originally Posted by xBULL3TxSP0NGEx View Post
    I haven't downloaded this yet, plan to this week, but is the tool with meshes and textures already implemented and functioning just as seen in the video available for purchase on CGTRADER? I looked but didn't see it on your page.
    Hi again, I added the models here on CGTrader. You'll get every mesh you see in the video + a roundabout as FBX, within a .blend file as well as .uasset which you can put into your "content" folder of your project. If you use the .uassets the sockets should already be set up and functioning. However you will have to create materials for the textures I supply with the CGTrader pack. I had to change the road as well as the intersection/brick texture, because I don't own the rights of the ones I show in the video. Have a look at the last three pictures on CGTrader to see what the new ones are looking like. However the meshes work with any tiling texture, so you could also for instance use this one with out any problems .

  5. #45
    0
    The Plugin dont work for me, when I press ALT + dragging the Point out the Mesh just duplicates

  6. #46
    0
    Hello, i'm new with the Ue4 and i'm asking if it's possible to use it for commercial used ?

  7. #47
    0
    Quote Originally Posted by xDennis0811 View Post
    The Plugin dont work for me, when I press ALT + dragging the Point out the Mesh just duplicates
    You'll have to select a spline point (usually a white square) and drag this out. If you select the mesh you'll duplicate it.

    Quote Originally Posted by suiksuiky View Post
    Hello, i'm new with the Ue4 and i'm asking if it's possible to use it for commercial used ?
    You can use this for commercially. However If you get any decent revenue consider to spend a small amount on stuff from my CGTrader account

  8. #48
    0
    Quote Originally Posted by Kamran Wajdani View Post
    From Where i can download this blueprint i am unable to find download link and attached file link is just blank text: http://prntscr.com/ephsfl
    I had the same problem in Mozilla Firefox, but it works with the Internet Explorer.
    Try another Browser! Hope it works

  9. #49
    0
    Can someone say how I use this road meshes ? ( or this one road mesh ) because i cant use this blend in my UE4 it doesnt work. what do i have to do with it ?

  10. #50
    0
    Could someone help me ? The streetmesh is not working for me idk what to do with this blend ...

  11. #51
    0
    Well, you'll have to open the .blend file with blender and export the meshes you like. The file is meant to show you how to construct your own street meshes.

  12. #52
    0

    Question

    Hey Bud,
    i sent a pm with details of my issue, this is the screenshot. For everyone else, this error log is on a fresh project, with a fresh RapidRoadTools installed, and none of the files referenced in the log have been used for the tool to need to reference them. How do i get rid of it all? Or doesnt it matter too much?

    My main project (hopefully due for release soon) where these errors became cause for concern, which has used this tool extensively, loads all the meshes correctly with all textures intact but still gives this error log.

    I love this tool and recommend it to anyone - ive used it for roads, intersections, walls, fencing, guard rails. So many uses =)
    Attached Images Attached Images  
    Last edited by SykoStace; 05-23-2017 at 08:23 AM.

  13. #53
    0
    Quote Originally Posted by SykoStace View Post
    Hey Bud,
    i sent a pm with details of my issue, this is the screenshot. For everyone else, this error log is on a fresh project, with a fresh RapidRoadTools installed, and none of the files referenced in the log have been used for the tool to need to reference them. How do i get rid of it all? Or doesnt it matter too much?

    My main project (hopefully due for release soon) where these errors became cause for concern, which has used this tool extensively, loads all the meshes correctly with all textures intact but still gives this error log.

    I love this tool and recommend it to anyone - ive used it for roads, intersections, walls, fencing, guard rails. So many uses =)
    Hi,
    I guess the original blueprint tries to find the meshes I used in my project at the location on my computer.
    Please try to replace the following meshes in the original road blueprint with your own meshes and see if the errors happen again:

    (On the left side)
    Street Mesh -> SplineMeshComponent -> replace all three entries with one of your local meshes (they will be your default meshes)
    End Mesh -> CrossMesh -> also, just replace it with one of yours (it will be the default end mesh)
    Landscape -> MarkingMesh -> Replace this with a normal plane and a UV map. The plane bounds should be 1uu/1uu. This is used to visualize where the impact of the landscape aligning will be.

    -siebencorgie

  14. #54
    0
    Yep that did the trick bud - the boxes were blank already but as soon as i changed them to my meshes the errors disappeared. Thanks heaps for that

  15. #55
    0
    @siebencorgie: Thanks for the great tool! It makes it much easier to learn how to create roads.

    I think i found the bug, why applying to the landscape creates strange scratches:
    In the align to surface function you start the line trace at the SplinePoint and end TraceDepths (10000) units down.
    If your SplinePoint is already on the surface, it doesn't hit any surface and then moves to a strange location.
    The problem also appears, when you click align to surface a second time, because all SplinePoints are already on the surface.

    So, if you start your LineTrace 1 unit up (or TraceDepths units up) your SplinePoints always align to surface.
    Now its also possible to align multiple Splines to the surface.
    Last edited by hannes.b; 06-06-2017 at 02:22 PM.

  16. #56
    0
    I tested this, it looks good but the created spline mesh has no collision. How do I get collision working?

  17. #57
    0
    Quote Originally Posted by overreal View Post
    I tested this, it looks good but the created spline mesh has no collision. How do I get collision working?
    I just tested this too and I found a fix. In newer versions of UE4 you can't modify a static mesh's collision after it's been spawned (as it was done in this blueprint), but you can just set it in the "AddRoadToSpline" function (It's in the functions list of the RapidRoadTool blueprint), click on the "Add Spline Mesh Component" and collisions options should pop up on the right. Set "Collision Presets" to "BlockAll" or whatever you like and it should work.
    TREPANG2 - Indie FPS with slow motion, epic 3 way shootouts.


    IndieDB
    Thread
    Demo!

  18. #58
    0
    Hey, this is awesome! It works fine in the editor but in my Map Log and in the Build Log which everytime failed are the following errors:

    Name:  Capture.PNG
Views: 318
Size:  137.5 KB

    I dont know if this is the reason for the failed builds but can you help me to fix this ?

  19. #59
    0
    Quote Originally Posted by Sky001 View Post
    Hey, this is awesome! It works fine in the editor but in my Map Log and in the Build Log which everytime failed are the following errors:

    Name:  Capture.PNG
Views: 318
Size:  137.5 KB

    I dont know if this is the reason for the failed builds but can you help me to fix this ?
    Hi, I guess this is the same problem @SykoStace found some replies earlier. Try this fix:

    Quote Originally Posted by siebencorgie View Post
    Hi,
    I guess the original blueprint tries to find the meshes I used in my project at the location on my computer.
    Please try to replace the following meshes in the original road blueprint with your own meshes and see if the errors happen again:

    (On the left side)
    Street Mesh -> SplineMeshComponent -> replace all three entries with one of your local meshes (they will be your default meshes)
    End Mesh -> CrossMesh -> also, just replace it with one of yours (it will be the default end mesh)
    Landscape -> MarkingMesh -> Replace this with a normal plane and a UV map. The plane bounds should be 1uu/1uu. This is used to visualize where the impact of the landscape aligning will be.

    -siebencorgie

  20. #60
    0
    Help, I can't seem to find the download link... am i missing something or has the download link been removed...?

  21. #61
    0
    Samaritan
    Join Date
    Jun 2015
    Posts
    93
    Quote Originally Posted by gaitara View Post
    Help, I can't seem to find the download link... am i missing something or has the download link been removed...?
    It still is attached at the bottom of the first post.

  22. #62
    0
    Quote Originally Posted by siebencorgie View Post
    ...
    Of cause there are bugs:
    • Applying to landscape sometimes creates strange hightmap "scratches" (seems to be an blueprint/engine bug)
    • When connecting to an "End Mesh" the incoming spline is strangely deformed (you'll have to play with the tangent length to fix that)

    ...
    @siebencorgie:

    I think i found also the bug with the strange heightmap scratches.
    The scratches appear, when there are 2 spline points too close to each other.

    For example: if you click the "Add End" Button and dont move the second spline point, but add a third spline point, then there will be a scratch starting at the 2 very close spline points.

    So if you have a minimum distance between each spline point, then there will be no scratch in the landscape

    Thanks for the great tool! i like working with it and hope i can help you fixing the last bugs

  23. #63
    0
    Quote Originally Posted by gaitara View Post
    Help, I can't seem to find the download link... am i missing something or has the download link been removed...?
    @gaitara:
    please try another browser! I had the same problem with mozilla firefox, but it works with internet explorer

  24. #64
    0
    Is this continued to be improved by the original dev or are any people expanding it as another project?

  25. #65
    0
    Quote Originally Posted by siebencorgie View Post
    Landscape -> MarkingMesh -> Replace this with a normal plane and a UV map. The plane bounds should be 1uu/1uu. This is used to visualize where the impact of the landscape aligning will be.
    Could you give a little more detail of how this should be? Or perhaps provide a sample .uasset file?

    -Brian

  26. #66
    0
    I'm having the same problem. It's not at all clear to me how or where to create sockets to attach roads onto the intersection geometry. The interface is different than the one in the tutorial and I've tried clicking on various things but just guessing badly.

    Here is what I can do:

    I can make a road and add new sections to it.
    I can add an intersection end geometry to it.

    Here is what I can't figure out:

    Where in the menu I go to create sockets to then have the roads go right left front from the intersection.

    There seems to be a number of choices.

    Is it End Mesh
    End attachment
    Cross Extra?

    If it's Cross Extra, when I click on the create end socket button nothing seems to happen. But I have no idea what I'm doing.

    Please could someone instruct me in detail?

  27. #67
    0
    Infiltrator
    Join Date
    Jun 2017
    Posts
    22
    looking good, i can try this tool

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •