Can you confirm that as of 4.20 you need High Sierra 10.13.5 minimum to run it on OSX?