first make sure the static mesh has collision and second make sure under the foliage tool the Static mesh option is enabled its under the brush optio...