Fixed the issue.

Turns out lowering your near clip plane causes this for some reason.
I set it back to default 10 from Project Settings....