Under TargetActor in the BlackBoard key you have it set to object which is correct. However, below there are options as to its type. Change it to Actor....