My personal theory is that the Google VR plugin used in UE4.21 and later only works with Daydream compatible phones. It works for me in UE4.20 on a GalaxyJ7...