That's a shame, I knew there would be some hairy edge cases such as when the DLC is built and linked to an outdated or different version of the "core"...