I ran into this same issue today and stumbled upon this post. If I disable "Cast Ray Tracing Shadows" on the spotlight it acts how you would...