Try unchecking "Affect distance field lighting" per object. I was getting inky shadows on some rocks and they went away when I unchecked "dynamic...