Announcement

Collapse
No announcement yet.

Weird difference in render height/priority between particle's emitters (spark/smoke/etc)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Weird difference in render height/priority between particle's emitters (spark/smoke/etc)

    I use one of the basic explosion particle emitters from UDK, there's one area where combat gets very close to terrain for effect, when that happens the explosion particles (with SDPG_Foreground set on the emitter) will show the sparks on top of the terrain, but not the smoke and fireball.
    Could anyone help me figure out what causes this difference? Because looking at it in Cascade, the emitters have very similar properties, so I don't see why the sparks would show while the smoke and fireball get obscured...
    Maybe it's because smoke and fireballs are done with flipbooks, but even then it should be possible to get them to render on top, without changing the Z location so much that the effect is placed inaccurately.


    #2
    With meshes there was a rendering priority maybe particles have the same? Something like foreground and such... I am just trying to help I don't even remember the variable name.
    Some cool unreal projects you may like!


    Developer of GOTA - Survivalism Gladiatorial game Buy the game google gladiators of the arena steam https://store.steampowered.com/app/7..._Of_The_Arena/

    Download the demo Download the demo
    external link Dropbox DropBox

    Become a c++ Professional now C++ Networking Tutorial

    Comment


      #3
      You can use translation on them in the emitters properties. Then you should be able to move them where you want them. to move like 5 feet in front of you, one of the settings is like 200 to 250 to get it to move that far. I used this on our rain emitter attached to our player, to back it off so the 1st person could see it all the time in his face.
      Last edited by gamepainters; 11-02-2020, 06:20 PM.

      Comment


        #4
        Originally posted by Neongho View Post
        With meshes there was a rendering priority maybe particles have the same? Something like foreground and such... I am just trying to help I don't even remember the variable name.
        Yeah, I'm using SDPG_Foreground.

        Originally posted by gamepainters View Post
        You can use translation on them in the emitters properties. Then you should be able to move them where you want them. to move like 5 feet in front of you, one of the settings is like 200 to 250 to get it to move that far. I used this on our rain emitter attached to our player, to back it off so the 1st person could see it all the time in his face.
        I can give this a shot, moving the whole particle object definitely didn't work, it would get moved out of position and still render behind terrain somehow.

        Comment


          #5
          Hmm, nope, they are badly offset and still render behind terrain, there's something weird going on with flipbook animations.

          Comment


            #6
            Are you using a translucent material on the emitter? if so there is a setting in the properties to render that on top or some thing like that, check that box. I had the same issue with my see thru ribbons for the out of bounds markers. i checked that box and it solved it. You could see my ribbons exactly how your describing your emitter. Not sure if this is the same issue, but it sure sounds the same.

            Comment


              #7
              Originally posted by gamepainters View Post
              Are you using a translucent material on the emitter? if so there is a setting in the properties to render that on top or some thing like that, check that box. I had the same issue with my see thru ribbons for the out of bounds markers. i checked that box and it solved it. You could see my ribbons exactly how your describing your emitter. Not sure if this is the same issue, but it sure sounds the same.
              Sounds promising but I couldn't find that property, is it one of these maybe?

              Comment


                #8
                pretty sure it the one above Allow fog. been a few years sense i set that, but i am pretty sure that is the one.

                Comment


                  #9
                  Kind of sounds like the problem I was having( didn't found a solution yet)

                  https://forums.unrealengine.com/lega...-for-particles

                  Comment


                    #10
                    Originally posted by gamepainters View Post
                    pretty sure it the one above Allow fog. been a few years sense i set that, but i am pretty sure that is the one.
                    Nothing changed sadly, even after fiddling with all those checkboxes.

                    Originally posted by O_and_N View Post
                    Kind of sounds like the problem I was having( didn't found a solution yet)

                    https://forums.unrealengine.com/lega...-for-particles
                    Hm, it doesn't look like the particles are overriding each other, it's only the terrain causing problems, things only change when terrain proximity is involved.

                    Comment


                      #11
                      wow, bummer. That check box is suppose to render the scene behind the translucent material not in front like it sounds like it is doing.I figured this would solve that for you. i will install my old version just so i can see if that is all i set to get that working.

                      Comment


                        #12
                        Originally posted by O_and_N View Post
                        Kind of sounds like the problem I was having( didn't found a solution yet)

                        https://forums.unrealengine.com/lega...-for-particles
                        if I understand correctly you want to change the sorting of the different systems inside the emitter?
                        i.e. take a look at this picture. you want to determine the order in which "Primary", "Fire_Dup" and "FlareCore_Dup" get rendered?
                        if that's the case, unreal sorts these from left-to-right in the order they are displayed in that very window. In this example Primary will be rendered first, then Fire_Dup is rendered on top, and then FlareCore_Dup. so FlareCore_Dup is what you see rendered on top.
                        if you want to reorder the systems just select the emitter and press the left/right keys in your keyboard


                        if the issue is with proximity of other objects, double check the material as it might be doing a depth fade
                        Follow me on Twitter!
                        Developer of Elium - Prison Escape
                        Local Image-Based Lighting for UE4

                        Comment


                          #13
                          Originally posted by Chosker View Post

                          if I understand correctly you want to change the sorting of the different systems inside the emitter?
                          i.e. take a look at this picture. you want to determine the order in which "Primary", "Fire_Dup" and "FlareCore_Dup" get rendered?
                          if that's the case, unreal sorts these from left-to-right in the order they are displayed in that very window. In this example Primary will be rendered first, then Fire_Dup is rendered on top, and then FlareCore_Dup. so FlareCore_Dup is what you see rendered on top.
                          if you want to reorder the systems just select the emitter and press the left/right keys in your keyboard


                          if the issue is with proximity of other objects, double check the material as it might be doing a depth fade
                          Thank you my friend.Will try it out again from the ground up in a few days.There is also the possibility that the udk fog(or my separate fog material) is also accomplice so I will deactivate it and even try in dx9 mode just in case there is something strange on dx11(which wont be the first time).

                          Comment


                            #14
                            After checking our ribbons out. That was all i had to do was check that button to solve our problem.

                            Comment


                              #15
                              Originally posted by gamepainters View Post
                              After checking our ribbons out. That was all i had to do was check that button to solve our problem.
                              Thanks for checking it out, I think i'll just leave it alone because it's a situational problem.

                              Comment

                              Working...
                              X