Announcement

Collapse
No announcement yet.

Disable reduced SkelMesh anim FPS when out of frame

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Disable reduced SkelMesh anim FPS when out of frame

    I have a skelmesh anim for rendering a fish in my fishing simulation.

    I attach a fishing line mesh to a socket on the fish's mouth so the line moves as the fish fights.

    The trouble is, when the fish is out of sight, it's animation reduces in FPS, leading the fishing line jerking around at a low framerate.

    Does anyone know how to disable the dropped FPS to the animation?

    Edit: Increasing the BoundScale (so that the bounds are in the player's view) works, but this is heavy-handed, and I can't control this through script. Any ideas on how to set it to ignore occlusion bounds checks?
    Last edited by Coldscooter; 10-17-2020, 03:47 PM.

    #2
    Have you tried this in pawns?

    /**If MaxDistanceFactor goes below this value (and it is non 0), start playing animations at a lower frame rate
    var() float AnimationLODDistanceFactor;

    /** Rate of update for skeletal meshes that are below AnimationLODDistanceFactor. For example if set to 3, animations will be updated once every three frames.
    var() int AnimationLODFrameRate;

    /** High (best) DistanceFactor that was desired for rendering this SkeletalMesh last frame. Represents how big this mesh was in screen space
    var const float MaxDistanceFactor;
    Provisional blog: http://cobaltudk.blogspot.com.es/
    Videos: https://www.youtube.com/user/cobaltudk
    Facebook: https://www.facebook.com/babylonprojectgame/

    Comment


      #3
      there's also a bool UpdateSkelWhenNotRendered (or something along those lines) which might help
      Follow me on Twitter!
      Developer of Elium - Prison Escape
      Local Image-Based Lighting for UE4

      Comment


        #4
        Thanks for suggestions. I tried all those settings and the animation still played at a reduced rate.

        I ended up just dynamically swapping out the skelmesh component for one with a very large bounding box, just for the player holding the fishing rod, which has fixed the issue.

        Seems like a bit of a hack though, as i would have expected some of those other settings to work.

        Comment


          #5
          UpdateSkelWhenNotRendered this is important if you want traces to work... if not there... well what chosker said.
          Some cool unreal projects you may like!


          Developer of GOTA - Survivalism Gladiatorial game Buy the game google gladiators of the arena steam https://store.steampowered.com/app/7..._Of_The_Arena/

          Download the demo Download the demo
          external link Dropbox DropBox

          Become a c++ Professional now C++ Networking Tutorial

          Comment

          Working...
          X