Announcement

Collapse
No announcement yet.

Did anyone found how to cook in dx11?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Archon..do you really think that calling us ''morons(seems to be edited,but I remember) and addressing us as udk class'' and than continue to ask questions is the correct way to approach the community?
    Im not even sure why im doing this, but as I said, I am not a coder.The file is most probably a visual studio save file of the project.Start by installing visual studio, its free.After that watch the video closely.


    Comment


      #17
      do you really think that calling us ''morons(seems to be edited,but I remember)
      when you Blend Out,Why i did so,Than sure it might look this way.. i told the reason and i removed certain things,since this section is for DX11.

      addressing us as udk class
      do you feel insulted by this?you,yourself said it´s a small com.this small remain of UDK user is like a class.

      and than continue to ask questions
      I´m not a Enemy,just a Helping Spirit what you kind of Called from the depths..i arrived here as a nice Guy,Helping and open minded.
      but your Distance and the lack of Human Qualitys makes me angry torwards your Attitude,how you handle new members with their Individual Background,as well how you Reply,When you folks Even Reply!

      putting me in the corner of a Bad and Stupid guy is Lame.
      i told you also i don´t go further into this,it won´t take an end..(after a while,i´ll delete this as well.i do not intend to spam.)

      why you´re doing this?
      it´s not for me,it´s for the Forum and Those who Seeks for Answer..

      i mean you can Behave like a insulted teen Girl,but i think it Don´t suits you..+my Game Progress depends not from You!
      i fixed the most by my self instead making stupid new posts.the only you helped me is with the 64bit trick.
      That´s it.

      I hoped also with the DX11,but only vage clues..i don´t like that sort of Tutorials.

      When you can Handle this like a Men,than i Suggest we Finally move on!?
      and work together?!Brainstorm things Together,Rise together..


      or remain Silence for all Eternity like you did with the image..


      You Decide.





      Portfolio:
      https://mega.nz/folder/ZkNi1CyY#vOp4PSahLibmlOeILlG20Q (copy,right click..)
      https://mega.nz/folder/0QIB3A5C#ig9a2cmg1jcfAh4WcJ1aMQ

      Comment


        #18
        i will continue to do this for seekers..



        the Second Post of this Section says:

        "So a external exe start button that opens the UDK.exe with no desktop shortcuts or anything like that.
        Seems to work as the window says that the udk game is in dx11 mode.
        Should this be the only way to do it?"

        he linked other posts sites,but none of them has something or slightly to do with DX11..

        https://forums.unrealengine.com/lega...-working-again
        https://www.youtube.com/watch?v=z2hk...T18itg&index=1
        https://forums.epicgames.com/udk/udk...etup+blank+exe
        https://forums.epicgames.com/udk/udk...ses#post187956
        https://forums.unrealengine.com/lega...ve-load-kismet


        he also claims,that it´s working,just following the video..
        https://www.youtube.com/watch?v=hgSq...ature=youtu.be

        "
        About the youtube video.I am not a coder and have 0 experience in visual studio,but just pausing the video and doing everything he does,step by step, I created a simple wrapper exe that launched the game in dx11.I really cant make this more simple as its on a video already.If it makes any difference, i believe i watched it and followed it only to min 5 in order to make the start launch button which was what i wanted to try.>launch the game in dx11 from a external exe."

        "I haven't uploaded to steam to try the launch params as Coldscooter said, but im sure it will work.The thing that i tried on my pc was from post 2 here.Make a wrapper .exe using visual studio from the youtube tutorial.It was just a external exe and nothing more.(and yes it worked)

        Looks like it will be just better to say to steam to launch the udk exe with -dx11 command for a final build when the time comes."


        i don´t know why they have to connect to steam in order to run it in DX11..?

        than,he made another sketchy hint..

        "
        About the manifest, it is just a epic games manifest.I was scratching my head too and it seems that versions of udk 2012? and up have some unneeded security measures or something that makes the windows firewall jump in.Cant remember but here is my thread about the manifest and the information I was able to get with the help from others."

        i guess this was related to frontend 1.6.5 and not to DX11..

        either the video of the originator nor the video of the coding part from his second post shows anything about DX11.i expected to see it in the launcher..None of the video sealed the deal.
        so,i must go through in order to tell you Linear and properly if that truly worked,even above version 2012?!

        but before,i contacted the originator of the coding video,and asked him to explain,he just gave me than this:
        https://www.youtube.com/watch?v=hgSq...ature=youtu.be

        https://www.dropbox.com/s/fnk46zi0kl...ncher.zip?dl=0

        well,it was rather a upload because the link went broke.
        what means,no need to work through all 2-3 parts,but pay attention to the last part,where to install..



        Is It Now,working!?
        -in Progress..




        Archoneater
        Last edited by Archoneater; 12-02-2020, 05:47 AM.
        Portfolio:
        https://mega.nz/folder/ZkNi1CyY#vOp4PSahLibmlOeILlG20Q (copy,right click..)
        https://mega.nz/folder/0QIB3A5C#ig9a2cmg1jcfAh4WcJ1aMQ

        Comment


          #19
          Ok,

          so i went into this field,what´s new to me.the non linearic tutorials,sketchy hints and also the lack of certain important features what´s not fully documented is by Epic.
          but Epic does not to do so,because they gave the user alot of freedom+access to nearly all features and it´s for free! i´m greatfull for this..

          there are Alot of post´s to this topic and problem Fields what´s related to the Cooking and Packaging process.
          No wonder,people loose the Overview and with that also the interest.


          ---------------- Packaging and Run exe.as DX11 in 64bit ----------------- (Simple Version)

          The Originator´s Post(Majic12),is Related to the 64bit Cooking and Packaging process.by Combined these with the Hint from the old forum,Brings the Fast and Wanted result.

          ///////////////////////////////////////////////////////////////////////////////////////////////////////////////

          Go To:

          1. C:/UDK/UDK-2015-01/Binaries
          2. locate the "UnSetup.Manifests.xml"
          3. open the xml file with a editor,like Notepad++
          4. change in line 5 <AppToLaunch>Win32\UDK.exe</AppToLaunch> to Win64\UDK.exe
          5. as well in line 106 <string>Binaries/Win64</string> to Win32.

          now,Cook your project in "UnrealFrontend" or "UDKFrontend" with Default settings,mostly unchecked.add your map and hit the button.
          after you finished installing,simply Find the Shortcut Properties of the Launch Icon, and set the Target
          to C:\UDK\yourname\Binaries\Win64\UDK.exe -seekfreeloading -dx11.

          when you run the .Exe,it should appear in 64bit dx11.

          you probably Noticed,the missing BSP´s as well missing
          Texture´s,on it+some other textures from the Epic Content..

          leave the BSP´s Away.work instead only with your Imported Model´s(fbx) as well your Textures.and Avoid Map Names like "Dlight_light_opt." prefix,suffix stuff..

          you noticed also the insane loading time?not always the case..,Try 32bit in dx11 instead 64bit.
          64bit works better with dx11.for the case,it might crash with dx9..

          and you probably Noticed also,while you Cook and Package your Project with TranslucentShadows or Distorted Glass materials,
          a Compile Problem,in Yellow.UDK will take the Default setting for this,to fix it.same goes for the Sound Cue and the Supported Game Type

          But,That´s No Problem,
          when you run your .exe in dx11,Materials will be re-Compiled and should work fine.

          ////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

          Proper Basic Tutorial,Click Next,at the Bottom..

          https://subscription.packtpub.com/bo...ontent-browser

          References:
          https://forums.epicgames.com/udk/udk...ook-dx11-build
          https://forums.epicgames.com/udk/udk...-packaged-game

          Video Tutorials:
          https://www.youtube.com/watch?v=luuz...2BB66D&index=6
          https://www.youtube.com/watch?v=W0zt...2BB66D&index=2
          https://www.youtube.com/watch?v=shTR...2BB66D&index=1
          https://www.youtube.com/watch?v=2OAt...2BB66D&index=5
          https://www.youtube.com/watch?v=ukaf...2BB66D&index=3

          -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


          ---------------- Packaging and Run exe.as DX11 in 64bit ----------------- (Advanced Version)


          ..To say ,there is no other way,is not fully applyable to UDK,since the Unreal Engine provides multiple ways.with other words
          "you can tweak the hell out of this engine".

          I came also across other Tutorials,which involves Deeper Solution to probs.what more Advanced Developer might one day face,you might look into it..


          https://forums.epicgames.com/udk/udk...custom-scripts
          https://forums.epicgames.com/udk/udk...x11-by-default
          https://forums.epicgames.com/udk/udk...t-save-problem
          https://forums.beyondunreal.com/thre...s-help.180862/
          https://www.epicgames.com/unrealtour...-packaging-map
          https://forums.epicgames.com/udk/udk...p-getting-lost
          https://forums.epicgames.com/udk/udk...-importing-ase
          https://forums.epicgames.com/udk/udk...-packaged-game

          https://forums.tornbanner.com/topic/...m-doesn-t-work


          About the "My Game Launcher" project file from the download link..
          https://www.youtube.com/watch?v=hgSq...ature=youtu.be

          i left my UDK in 32bit,followed at the end the steps of inserting the launcher at the right place as well the DLL,but it´s not working..i placed it in the udk folder as well in my packaged exe. directory,but it´s not working!maybe because the developer is working with UDK 2011,don´t know for sure..

          i have no VS,so i can´t look into and change the Path,for example in 64bit+dx11.should be a kind spirit arround here and read this,please provide the file in the correct form,so the path are set properly and in 64bit+possible dx11.



          something else..

          when you change in line 5 of the "UnSetup.Manifests.xml" <AppToLaunch>Win32\UDK.exe</AppToLaunch> to <AppToLaunch>Win32\UDK.exe -dx11</AppToLaunch> as well,checked in frontend (exec commands )-dx11.

          you will get along the exe installer a zipped directory what contains the Binaries,Config and the UDKGame+ a DotNetZip-idftvwp1.tmp !?
          normally it vanish after the cooking,but it remained plus it zipped the other files..i´s tlike a Portable version,Installed Mode? from the frontend?

          i wish i could say "case closed",but we´re dealing here with the Flexible unreal engine and every fifth,faces Individual problems.


          Archoneater
          Last edited by Archoneater; 12-02-2020, 12:06 PM.
          Portfolio:
          https://mega.nz/folder/ZkNi1CyY#vOp4PSahLibmlOeILlG20Q (copy,right click..)
          https://mega.nz/folder/0QIB3A5C#ig9a2cmg1jcfAh4WcJ1aMQ

          Comment

          Working...
          X