Announcement

Collapse
No announcement yet.

Annoying problem(UDKEngine)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Annoying problem(UDKEngine)

    I noticed since a few months a incredibly annoying problem that happens in udk and installed udk games.In config>UDKEngine I have manually set bSmoothFrameRate to be FALSE as i want the 120fps.It works for a few days and just randomly the thing goes back to TRUE???!!! Same happens with installed games.They work for a few days or even weeks on 120fps and for some strange reason the UDKEngine resets it self to bSmoothFrameRate=TRUE capping the game to 62fps.

    Someone please provide me a reason for this as i just cant understand it.It happened on 2 machines.
    Im not sure if the problem has always been there.So it was a recent find on my part.
    Last edited by O_and_N; 02-12-2020, 04:45 PM.

    #2
    I just set MaxSmoothedFrameRate to whatever I want and leave bSmoothFrameRate to true.

    If you really wanted to, you could always forcibly set it true each time the game loads.

    Comment


      #3
      Originally posted by Coldscooter View Post
      I just set MaxSmoothedFrameRate to whatever I want and leave bSmoothFrameRate to true.

      If you really wanted to, you could always forcibly set it true each time the game loads.
      I will set it to 120 now and see if it will stay like that.By the way, how can i force it every time the game or engine start?

      Comment


        #4
        O_and_N Something like this would do it:

        Code:
        class'Engine'.static.GetEngine().bSmoothFrameRate = false;
        And then to save it to the .ini file:
        Code:
        class'Engine'.static.GetEngine().SaveConfig();
        I would advise against setting bSmoothFrameRate to false though, rather than just increasing the MaxSmoothedFrameRate .

        Comment


          #5
          I have a fps limit in the game setup, so when the game starts:

          class'Engine'.static.GetEngine().MaxSmoothedFrameRate = value;

          and no problem until now.

          Also I use:

          class'Engine'.static.GetEngine().MinSmoothedFrameRate = 25;

          if I remember, if the framerate is lower than this, the game begins to drop detail.
          Provisional blog: http://cobaltudk.blogspot.com.es/
          Videos: https://www.youtube.com/user/cobaltudk
          Facebook: https://www.facebook.com/babylonprojectgame/

          Comment


            #6
            Thank you guys,will do it now and hopefully it wont reset again.

            Comment

            Working...
            X