Announcement

Collapse
No announcement yet.

Varying flipbook playback

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Varying flipbook playback

    I'm using flipbook textures to show flocks of birds in the sky as a panning texture.

    My problem is that they all flap their wings in synchronisation. In the UDK docs it mentions this issue:

    NOTE: Flipbook textures suffer the same problem as movie textures in that the same source flipbook texture will be in sync when used on multiple objects in a scene. There is a TTP to remedy this issue for flipbooks.
    What is a "TTP"? Does anyone know how to fix this?
    Last edited by Coldscooter; 10-12-2019, 08:42 PM.

    #2
    This is how far I've got it without variable playrate on the flipbook texture:


    It just bugs me that all of their wings are flapping in synchronization (although it is somewhat masked by running parallax panners on the flocks).

    Comment


      #3
      I don't know what a TTP is, but this is how you can fix it:

      Make a particle system. Give it a mesh particle emitter. Give that emitter your bird mesh and material instance. Give the emitter the property Parameter -> Dynamic. For the Dynamic property, set Spawn Time Only, and give it a distribution of a uniform range, with highs and lows that make sense for your material instance. Go into the parent material of the material instance, and give it a mesh emitter dynamic parameter. Add that to the time function that you use for switching the frame. I'm assuming it's some variation on floor(time) plugged into a panner, plugged into a texture coordinate. Just add the red channel of the mesh emitter dynamic paramter to time before you plug it into floor.

      If you do that, all the birds in the particle system will have a random offset to time when they flap their wings.
      Last edited by Nathaniel3W; 10-14-2019, 03:15 AM.
      Check out Himeko Sutori, the upcoming tactical RPG where you control armies of over 100 unique characters.

      Comment


        #4
        Thanks for the idea Nathaniel3W However i wanted to avoid using a particle fx if possible. Currently I'm just using a single material on a mesh plane, which make it very performant. I've gotten around it by just duplicating the flipbook texture and running it at a slightly different frame rate. It seems a bit of a hack, but works at hiding the synchronization quite well.

        Comment

        Working...
        X