Announcement

Collapse
No announcement yet.

android arm64 build error.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    android arm64 build error.

    An error occurs when attempting to build android arm64.
    physx, scaleform gfx library is 32bit... Is there a way to get the library for the arm64 build of Android ?

    d:/android/android-ndk-r10e/toolchains/aarch64-linux-android-4.9/prebuilt/windows-x86_64/bin/../lib/gcc/aarch64-linux-android/4.9/../../../../aarch64-linux-android/bin/ld.exe: skipping incompatible ../External/PhysX/SDKs/lib/Android/\libPhysXCore.a when searching for -lPhysXCore 2> d:/android/android-ndk-r10e/toolchains/aarch64-linux-android-4.9/prebuilt/windows-x86_64/bin/../lib/gcc/aarch64-linux-android/4.9/../../../../aarch64-linux-android/bin/ld.exe: cannot find -lPhysXCore 2> d:/android/android-ndk-r10e/toolchains/aarch64-linux-android-4.9/prebuilt/windows-x86_64/bin/../lib/gcc/aarch64-linux-android/4.9/../../../../aarch64-linux-android/bin/ld.exe: skipping incompatible ../External/PhysX/SDKs/lib/Android/\libPhysXCooking.a when searching for -lPhysXCooking 2> d:/android/android-ndk-r10e/toolchains/aarch64-linux-android-4.9/prebuilt/windows-x86_64/bin/../lib/gcc/aarch64-linux-android/4.9/../../../../aarch64-linux-android/bin/ld.exe: cannot find -lPhysXCooking 2> d:/android/android-ndk-r10e/toolchains/aarch64-linux-android-4.9/prebuilt/windows-x86_64/bin/../lib/gcc/aarch64-linux-android/4.9/../../../../aarch64-linux-android/bin/ld.exe: skipping incompatible ../External/GFx/Lib/Android/Release_NoRTTI\libgfx.a when searching for -lgfx 2> d:/android/android-ndk-r10e/toolchains/aarch64-linux-android-4.9/prebuilt/windows-x86_64/bin/../lib/gcc/aarch64-linux-android/4.9/../../../../aarch64-linux-android/bin/ld.exe: cannot find -lgfx 2> d:/android/android-ndk-r10e/toolchains/aarch64-linux-android-4.9/prebuilt/windows-x86_64/bin/../lib/gcc/aarch64-linux-android/4.9/../../../../aarch64-linux-android/bin/ld.exe: skipping incompatible ../External/GFx/Lib/Android/Release_NoRTTI\libgfx_as2.a when searching for -lgfx_as2 2> d:/android/android-ndk-r10e/toolchains/aarch64-linux-android-4.9/prebuilt/windows-x86_64/bin/../lib/gcc/aarch64-linux-android/4.9/../../../../aarch64-linux-android/bin/ld.exe: cannot find -lgfx_as2 2> d:/android/android-ndk-r10e/toolchains/aarch64-linux-android-4.9/prebuilt/windows-x86_64/bin/../lib/gcc/aarch64-linux-android/4.9/../../../../aarch64-linux-android/bin/ld.exe: skipping incompatible ../External/GFx/Lib/Android/Release_NoRTTI\libgfx_as3.a when searching for -lgfx_as3 2> d:/android/android-ndk-r10e/toolchains/aarch64-linux-android-4.9/prebuilt/windows-x86_64/bin/../lib/gcc/aarch64-linux-android/4.9/../../../../aarch64-linux-android/bin/ld.exe: cannot find -lgfx_as3 2>collect2.exe : error : ld returned 1 exit status
Working...
X