Announcement

Collapse
No announcement yet.

Any idea why this is blurry?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Any idea why this is blurry?

    I can't figure out what is going wrong here.






    When I play the game, it looks like the camera is shifting quickly, but I'm printing the ViewTarget.POV.Location, rotation, and FOV, and none of them are changing. There's no camera shake playing. I'm controlling the depth of field dynamically, and I'm sure it's not the DOF. I have no idea what is causing this to happen.

    Any ideas?
    Check out Himeko Sutori, the upcoming tactical RPG where you control armies of over 100 unique characters.

    #2
    Not sure what may be causing this, but usually when i encounter anomalies like this, i will checkout previous commit versions of the code until i find where the issue was stable, and thus introduced. Sorry for maybe stating an obvious, but wanted to chip-in what i would do to debug.

    Comment


      #3
      have you tried disabling all postprocesses entirely? could be motion blur
      Follow me on Twitter!
      Developer of Elium - Prison Escape

      Comment


        #4
        Motion blur. Thanks. I'll check on that and disable the postprocess. The problem isn't consistent. Sometimes it seems to go away with zoom, and it's worse when zoomed in. I changed the game's camera to be zoomed out farther, with a narrower FOV, and that seemed to work around the problem. But if this reappears I'll give the postprocessing trick a try.
        Check out Himeko Sutori, the upcoming tactical RPG where you control armies of over 100 unique characters.

        Comment


          #5
          or play around with the motion blur params, there's something related to camera thresholds IIRC
          Follow me on Twitter!
          Developer of Elium - Prison Escape

          Comment


            #6
            Hello dude!

            I think this maybe Motion Blur, because I had a similar problem, on which I even opened this thread:

            https://forums.unrealengine.com/lega...era-transition

            My solution was just set MotionBlur=False on the UDKEngine.ini under [SystemSettings]

            I have done this because I don't want to use Motion Blur at all, however, I don't know if you are using in some parts, or in some situations on your game.

            Good luck!

            Comment

            Working...
            X