Announcement

Collapse
No announcement yet.

possible 21:9 widescreen?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    possible 21:9 widescreen?

    Got a widescreen monitor a week ago.Its a 2560x1080 one so nothing fancy.Works awesome for kismet,matinee and reference images but udk game looks to be stuck at 16:9?Any idea if its possible to force it to go 21:9 widescreen or is that something that needs to be coded in the full version? I know that some ue3 games like killing floor 2 do have widescreen support.
    In my testing on the monitor, the udk game only does 1080p with vertical black bars for the aspect ratio to fill in the empty space.

    #2
    What happens if you run:
    Code:
    setres 2560x1080
    from the console while in game?

    Comment


      #3
      I have that problem to
      Some cool unreal projects you may like!


      Developer of GOTA - Survivalism Gladiatorial game Buy the game google gladiators of the arena steam https://store.steampowered.com/app/7..._Of_The_Arena/

      Download the demo Download the demo
      external link Dropbox DropBox

      Become a c++ Professional now C++ Networking Tutorial

      Comment


        #4
        Originally posted by Coldscooter View Post
        What happens if you run:
        Code:
        setres 2560x1080
        from the console while in game?
        I'm terribly sorry for the delay as I was making hardware changes to my pc and coudnt use it for a week.Yes i did tried the command and its a hit or miss.I have 3 monitors.2x4k 27 inch ones and one 2560x1080 29inch one.I decided to make the ultrawide my primary monitor and in the monitor settings i changed the aspect ratio from ''wide'' to ''original''.

        So with this settings 1080p is with black bars but it looks like 2560x1080 now works without streching the image or adding black bars.
        So it looks like the ultrawide monitor has to be set as the primary one and have the aspect ration of it to be set to original in order to strech the image as it shoud.

        The problem is that udk is not giving true ultrawide experience.Not even near.Here is a example;

        1920x1080
        https://i.postimg.cc/wvhJQ4vz/1920x1080.jpg

        2560x1080
        https://i.postimg.cc/x85zWkMF/2560x1080.jpg

        As we can see, the 2560x1080f is croping the top and bottom part of the image.And moving the weapon to the left??(I say moving as i dont see more of the door on the right in either images.

        The only thing that comes to my mind is when someone select the 2560x1080 option to link this command to a different FOV like 100-110 to fix it?

        Im open to ideas.

        I also found a similar situation with this udk based game with 2 example images that show my situation
        https://steamcommunity.com/app/26569...437/?l=spanish

        Comment


          #5
          Hello my friend, by looking at your screenshots, it seems yes that changing the FOVAngle value on UDKEngine.ini is the best option for compensate this crop of the image, because for widescreen it should show a bigger area of the map not do a "zoom", which looks weird.

          Cheers.
          https://sites.google.com/view/udkultimate/

          Comment


            #6
            Well, after some testing I can say that if your players deffaut FOV is 90 on a standart monitor, than when changing to ultrawide, the FOV needs to go to 106.Not ideal way to do it, but its enough.Only problem is that it looks like the weapon is rendered in a different way, so the weapon is the only object that will stay cropped on the screen, unless you move it a few units up when activating the widescreen option.

            Comment


              #7
              It's good that you found a solution!

              In my case as I am using a third person camera, I did see yes a slighty different position of the camera whenever changing the FOV value, however, it is fine, nor perfect, however for me is good.
              https://sites.google.com/view/udkultimate/

              Comment


                #8
                Small edit.Looks like just by changing the FOV to 106 isnt going to be enough.It works on play on pc, but in a cooked game for some reason it doesnt.In order to make it work in a final build one have to change the FOV to 106 and change the aspect ratio of the camera from 1.7 to something between 2.5 and 3.Only than it will work as intented.

                Comment


                  #9
                  A script is r.setRes 2560x1080f (w,wf).

                  Comment


                    #10
                    Originally posted by Šimon Ustal View Post
                    A script is r.setRes 2560x1080f (w,wf).
                    That is for the resolution, but just typing that will only expand the image, but it will crop it.You also need the two camera values from above to get ultra wide without a crop on the image.

                    Comment


                      #11
                      21x9 aspect is 2560x1080? Should it be 2520x1080 for a 21x9 aspect ratio.

                      Comment


                        #12
                        Originally posted by O_and_N View Post
                        Well, after some testing I can say that if your players deffaut FOV is 90 on a standart monitor, than when changing to ultrawide, the FOV needs to go to 106.Not ideal way to do it, but its enough.Only problem is that it looks like the weapon is rendered in a different way, so the weapon is the only object that will stay cropped on the screen, unless you move it a few units up when activating the widescreen option.
                        The weapon has its own FOV. Look in UDKSkeletalMesh

                        Comment

                        Working...
                        X