Announcement

Collapse
No announcement yet.

Disable DOF for certain objects?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Disable DOF for certain objects?

    I use distance-based DOF just to soften the image for far away objects, However I'd like to disable it only for my skybox.

    Does anyone know if this is possible in UDK?

    #2
    I think UDK ignores DOF on translucent objects. If you want to disable DOF on your skybox, you could try making it translucent, but then set its opacity to 1. That could cause other issues though, like maybe with smoke or other translucent particles that would draw in front of the sky.

    Besides the translucency hack, I know of no other way to disable DOF on just one actor. Maybe you could do something crazy to draw the skybox in post processing.
    Check out Himeko Sutori, the upcoming tactical RPG where you control armies of over 100 unique characters.

    Comment


      #3
      Originally posted by Nathaniel3W View Post
      That could cause other issues though, like maybe with smoke or other translucent particles that would draw in front of the sky.
      depth sorting would be easily fixable by setting the skybox's Translucency Sort Priority to -1
      Follow me on Twitter!
      Developer of Elium - Prison Escape
      Local Image-Based Lighting for UE4

      Comment


        #4
        Thanks for the tips guys. I'll give that a shot.

        Comment


          #5
          isnt it something in the material or texture settings?
          sure i remember something like a "skybox" setting...
          tegleg.co.uk - indie electronic music label
          Android + HTML5 WIP Physics Game
          PC Games - Android Apps

          Comment


            #6
            I don't see any setting for skybox anywhere in the material editor or texture settings unfortunately.

            Comment

            Working...
            X