Announcement

Collapse
No announcement yet.

Help Cooking for PS3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Hello guys!!!

    I already solved the problem, it was indeed one static mesh that was causing this problem. This is static mesh is one of the emitters of my custom electric sparks particle system. So I did fix this static mesh in 3dsmax, then reimported to UDK, updated my particle system, and cooked the map for PS3.

    Here is a gameplay teaser of my game running on my PS3 (very soon I will create a new thread here to promote my game and provide a free demo for anyone to download and test it):

    https://www.indiedb.com/games/fursan...ameplay-teaser

    Leave a comment:


  • replied
    Hello guys.

    I already found the solution. It was indeed a particle system, a custom particle system I created, which had a mesh data (stati mesh), however, I forgot to fix this mesh for PS3 whenever exporting from 3dsmax. Now I already fixed the mesh, reimported in the particle system, recooked the map, now it is running on PS3 flawlessly.

    Now I want ask you guys something about gamepads in UDK. I don't know if that's because I don't play too much on consoles, so I am more used to keyboard and mouse, however I am realizing right now, that I feel a kind of input lag, on both Xbox360 and PS3 (playing on the consoles itself, and also playing with Xbox360 controller in UDK).

    The lag is not on the buttons itself, rather, it is in the analog sticks for both camera and movement.

    I feel like a half of second lag, just on the beginning of the movement. Like this. I am with my character idle, then I move the analog stick forward, so I feel almost 0.5 seconds of lag from the moment I moved the stick to see the character response in game, moving forward.

    The same for the camera, however, if I keep moving the analog sticks without stop (both movement and camera), the character runs perfectly on the map and the camera moves arround without any lag. In example for continuous moving the analog sticks, there is no lag, as for just moving one time the stick, there is a input lag of 0.5s.

    Is this normal? Is this acceptable for a game? Can I change it? I did search however could not find anything on the ini files about this "lag".

    Any help is appreciated.

    Edit: I found these on DefaultInput.ini, however I think it is just for the camera movement:

    [UTGame.UTConsolePlayerInput]
    bAutoCenterPitch=TRUE
    bAutoCenterVehiclePitch=TRUE
    AutoVehicleCenterSpeed=12000
    Dodge_Threshold=0.8
    SlowTurnScaling=0.1
    AutoCenterDelay=2.0
    bViewAccelerationEnabled=TRUE
    bDebugViewAcceleration=FALSE
    bTargetFrictionEnabled=TRUE
    bDebugTargetFriction=FALSE
    ViewAccel_YawThreshold=0.99f
    ViewAccel_DiagonalThreshold=.99f
    ViewAccel_BaseMultiplier=1.1f
    ViewAccel_TimeToHoldBeforeFastAcceleration=0.125f
    ViewAccel_RampSpeed=0.100f
    ViewAccel_MaxTurnSpeed=3.0f
    ViewAccel_Twitchy=0.98f
    MagicScaleForSensitivityMiddle=2.4f
    MagicScaleForSensitivityEdge=1.5f
    ViewAccel_PitchThreshold=0.66f
    ViewAccel_LookingUpOrDownBoundary=12000.0f
    ViewAccel_BackToCenterBoundary=3000.0f
    ViewAccel_BackToCenterSpeed=2.8f
    AutoPitchCenterSpeed=0.20f
    AutoPitchStopAdjustingValue=5.0f
    HoverBoardPitchMultiplier=0.5f

    [Engine.PlayerInput]
    MouseSensitivity=30.0
    Last edited by NIDAL NIJM GAMES; 11-08-2019, 08:39 AM.

    Leave a comment:


  • replied
    Just one thought, this line UCookPackagesCommandlet::CookStaticMesh() Address = 0x199aa88, the memory adress number can't help to find which asset in the map is causing this?

    Leave a comment:


  • replied
    Here is the crash screenshot

    Click image for larger version

Name:	image.png
Views:	162
Size:	170.9 KB
ID:	1683410

    Leave a comment:


  • started a topic [UDK] Help Cooking for PS3

    Help Cooking for PS3

    Hello guys!

    I need some help here from the UDK Forum Gurus.

    I am having a problem cooking a map I made for my game for PS3. As for PC and Xbox360 it is cooking perfectly.

    The issue is just with this specific map, as I did cook many other maps for PS3 and they cooked perfectly.

    I know that sometimes, some skeletal mesh may need to be changed in the 3d software before cooking for PS3, as the ps3 cooker uses the Playstation Edge Graphics Library to cook content, and sometimes, some meshes make this crash because of the smoothing groups and vertex welding. I know how to fix it, I even created a maxscript to do this fix automatically.

    What I want is to find a way to discover which asset is causing this problem. I will be giving here the logs and dump file to see if someone can identify what is causing this crash.

    Here are the log and dump files: https://drive.google.com/open?id=1jw...5-7080vBrRU2h4

    Thank you guys!!
Working...
X