Announcement

Collapse
No announcement yet.

Collision breaks InterpActor movement in Matinee

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Collision breaks InterpActor movement in Matinee

    I have some gates that open and close in Matinee, with an event in Kismet that triggers the Matinee. It works fine in the editor. But the gate-opening-and-closing is broken in-game.

    If set collision to none, the gates open and close just fine. But then of course, the gates don't block anything. If I set collision to block all, then the gates block movement. But then the opening-and-closing motion is unpredictable. Sometimes the gates open backwards. Sometimes they don't do anything at all.

    I think base rotation may also affect this somehow. I have a test level where the gates block all, and they open and close as intended. But their base rotation is (0, 0, 0). In-game, I had to rotate the gates into position.

    Have any of you run into this problem? How did you solve it?
    Check out Himeko Sutori, the upcoming tactical RPG where you control armies of over 100 unique characters.

    #2
    The gates are interpactors with phys interpolating on, right? Is the collision a hidden collision model or is it collide per polygon?

    Comment


      #3
      Yeah, InterpActors. Phys_Interpolating. I let the editor build me a simplified Y collision.

      ...

      And thanks, but I think I found a workaround...

      I just did something kind of stupid, but it works. In Kismet, I change the collision to None, then run the Matinee, and when the Matinee ends, I set collision back to BlockAll. It's working for now because I don't need the gates to collide while they're moving. (I don't need them to knock over KActors or push pawns into the water or anything.) So this works for me, I guess. But if I ever need collision while something's moving (like on an elevator), then I'll have to fix this issue for real.
      Check out Himeko Sutori, the upcoming tactical RPG where you control armies of over 100 unique characters.

      Comment


        #4
        Either way, this shouldn't happen.Still try to delete the auto collision you made and if the doors are not high poly, try to click that collide per poly checkbox in the door mesh model menu and see if that helps.
        Maybe delete the udkengine and restart the editor so that unreal can build a clean new one?(sometime helps if the editor has something corrupted)

        Comment


          #5
          I have done something similar on my game demo, on wich the player has to plant a bomb over a wall to destroy the wall. The wall itself is a fracture mesh, however the collision is set to none (in editor). So my solution to block the passage is to place a hidden blocking volume that I trigger it in kismet. In your case you can try to use a kismet action to hide and unhide this blocking model (hide whenever the doors are open, then unhide whenever the gates are closed).

          Good luck!
          UDKUltimate Engine, Create, Play and Share on PC, PS3 and Xbox360:
          https://sites.google.com/view/udkultimate/

          Comment


            #6
            Try enabling bCollideAsEncroacher in default properties. You'll have to subclass InterpActor.

            Comment

            Working...
            X