Announcement

Collapse
No announcement yet.

Particles show up correctly in my game and in distributed editor, but not in distributed game

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Particles show up correctly in my game and in distributed editor, but not in distributed game

    I have a particle system that is supposed to look clear and sharp. But when it shows up in the Steam version of the game, the particle effect is blurry when it's in front of a fog sheet. The particle effect draws correctly in my development build of the game, and even in the Steam-distributed editor, but not in the Steam-distributed game.

    The fog sheet is a boring square static mesh with a translucent material applied. Its translucency sort priority is -1 in my development build, and confirmed -1 in the editor that ships with my game.

    Toggling "game view" mode doesn't change how the effect shows up in either my development editor or the shipped editor.

    The particle effect is fine everywhere except in the shipped game. Any idea where I should look next to fix this?
    Check out Himeko Sutori, the upcoming tactical RPG where you control armies of over 100 unique characters.

    #2
    Relevant pics:




    Don't mind the color difference. That's just postprocess color correction based on location and time of day.

    Postprocess.... Is there a postprocess setting that could be messing up my particles during gameplay?
    Check out Himeko Sutori, the upcoming tactical RPG where you control armies of over 100 unique characters.

    Comment


      #3
      looks like it's being affected by depth of field. since transparent materials don't write to depth, the DOF thinks it's part of the background. there's a few workarounds for this: using separate translucency or not (which makes translucency render after DOF) for which you need to enable it both on the material and in the system settings ini,
      or using a specific translucency material flag related to translucency post depth something something (that would cause a bad outline since it would do like writing masked alpha into depth, but in your case your sprite already has a hard cut so it might not be an issue at all)

      the difference between cooked and uncooked/editor right now might be related to the 'use separate translucency' system setting. I have vague memories of the separate translucency setting affecting editor or cooked differently
      Last edited by Chosker; 02-20-2019, 04:53 AM.
      Follow me on Twitter!
      Developer of Elium - Prison Escape
      Localized IBL for UE4

      Comment


        #4
        Separate translucency! That was it! I have it enabled on my development build. I even set it in the build that I use for uploading to Steam. But that setting gets overwritten for whatever reason, from BaseSystemSettings.ini, when the game installs. I changed it in BaseSystemSettings.ini, and in my game's SystemSettings.ini, and hopefully that'll make it work now. Thanks Chosker!
        Check out Himeko Sutori, the upcoming tactical RPG where you control armies of over 100 unique characters.

        Comment

        Working...
        X