Announcement

Collapse
No announcement yet.

Any solution for the artifacts (the black stripes) using dynamic light with cascade shadows?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Had same Problem

    I had the same problem and yours sounds very similar take a look at the picture... If your using dynamic lighting it negates the need to have cast static shadows ticked in the dynamic light. I turned mine off and immediately the stripes (Banding) disappeared..
    Attached Files

    Comment


      #17
      Thanks for the idea, but there are no diference in my case. Perhaps you are using staticmeshes with precomputed shadows and a dynamic light with sorth range shadows? In that case the cascade only replaces the static shadows for the near objetcts.
      Provisional blog: http://cobaltudk.blogspot.com.es/
      Videos: https://www.youtube.com/user/cobaltudk
      Facebook: https://www.facebook.com/babylonprojectgame/

      Comment


        #18
        I can't say Colbolt. I was getting fed up with it so I replaced both the dominant directional light and the skylight with a fresh one ( I think Snipe recommended it) and worked through the settings watching the screen as I did so. The only setting I returned to the way I had it was using 'don't recompmpute static shadows'. I had that checkbox ticked and 'use global illumination unchecked. I had the dynamic shadow range set 20000 and in the skylight I had cast shadows unchecked (I don't think it casts shadows anyhow) I worked down the list trying everything in the dominant light and when I reached cast static shadows the lines suddenly disappeared when I unchecked it. I checked it and they reappeared. I disabled the skylight so I could be sure it wasn't being influenced by something else, but it done the same. It sort of made sense to me because I had don't use precomputed shadows and the dominant light was casting realtime shadows then trying to use static shadows as well might be confusing it.... Sorry it hasn't worked for you... It's bloody annoying. You'll be pleased to know it was quickly followed by a different problem... The honymoon period is over..
        Last edited by martin56jones; 07-31-2017, 07:32 PM.

        Comment


          #19
          I forgot to mention ... Turn the shadow filter quality to 'Low' as well 'medium' & 'High' both produce the banding....

          Comment


            #20
            There are a lot of factors here, the cascade shadows values (distance, exponent, cascade number), the shadow map size, the CMS* variables like "CSMSplitDepthBiasScale", the orientation of the faces to the light, or the shadowdepthbias. For example with this last:

            Click image for larger version

Name:	shadowbias.jpg
Views:	1
Size:	186.9 KB
ID:	1131890

            With a bias of 0.05 the problem dissapears almost totally, but the shadows are less precise, some details are lost, like the belt shadow in the back of the character, or the woods in the house.

            You can play with the values, for example with the cascade shadows. You can set the values and find some that don't produce the stripes. Then move the camera, and the stripes appears again, at other distance, at other angle. It's very frustrating.

            So my plan is:

            - Try to align the meshes in the map to don't be paralel with the sun. But this don't works when the light is totally perpendicular to the ground (12 hours).

            - Shadow bias will change the value from 0.02 to 0.05, from 8:00 hours to 12, and from 0.05 from 12 to 16 hours. At 12 hours, the sun is vertical and a high bias are not too noticeable. As the day/night cyle are done with code and not matinee for performance reasons, it will be easy to add the bias to the interpolations.

            I don't know if there are any parameter in the ini's to fix this, I have touched a lot and the only thing that seems work is the bias. Also the pfc shadows can mitigate a bit, but I don't like the result too much. Perhaps some combination, some hidden option. Who knows (Epic staff appart).
            Provisional blog: http://cobaltudk.blogspot.com.es/
            Videos: https://www.youtube.com/user/cobaltudk
            Facebook: https://www.facebook.com/babylonprojectgame/

            Comment


              #21
              Using DX11 seems to solve the problem almost completely.

              I'm considering to move to Dx12, but my problem with it is that it's slower than dx9, especially when rendering skeletalmeshes. In my 100 bots test, dx9 gives 130 fps, and dx11 40 fps... but in the game the difference seems lower, with the skeletalmeshes more disperse, I think.

              Also there are some good things like SSS. There are a problem with the specular in materials, but it can solved easily and with no extra performance loss: https://forums.epicgames.com/udk/udk...-movable-light


              Provisional blog: http://cobaltudk.blogspot.com.es/
              Videos: https://www.youtube.com/user/cobaltudk
              Facebook: https://www.facebook.com/babylonprojectgame/

              Comment


                #22
                I've found shadows in UDK's DX11 to look slightly worse (a bit more jagged edges) compared to DX9 but maybe it was just pointlights and not directional lights.
                the performance difference seems not worth it though
                Help me back! follow me on Twitter
                Developer of Elium - Prison Escape

                Comment


                  #23
                  CobaltUDK: "Using DX11 seems to solve the problem almost completely"

                  Hi Cobalt,
                  I was having this issue too in .13 but have just updated my engine to .18 and it's NEARLY completely removed these intense artifacts for me.

                  I know there were some lighting improvments in the new update engine but I didn't realise they made changes to this side of thing- the movable lights and hiw they cast shadows etc...

                  When I get a chance I'll post some screenshots of before in .13 and after in .18 so you can see the difference. They are still there but much much less visible which is great.
                  As I'm doing my polys just with shaders though and no textures at all the problem was really apparent.

                  Anyway, I'll continue testing the scene and let you know the results here- I hope I didn't celebrate too early on this..!

                  Btw, are you using completely dynamic/movabke lights yes, for real time of day? If so, could you post your settings for the Skylight and the main Directional Light so I can compare what we have?


                  Ah sorry..! Just realised this is for UE3 whereas I'm using UE4..! Not sure if my post is still relvant though..!
                  Last edited by meshcarver; 11-23-2017, 04:23 AM.
                  Website
                  Artstation
                  Twitter

                  Comment


                    #24
                    Ah, how lucky that ue4 keeps updating.
                    Last edited by CobaltUDK; 11-23-2017, 07:07 AM.
                    Provisional blog: http://cobaltudk.blogspot.com.es/
                    Videos: https://www.youtube.com/user/cobaltudk
                    Facebook: https://www.facebook.com/babylonprojectgame/

                    Comment


                      #25
                      I just came across this post, I had the same question. The way I solved the problem was to reduce "Dynamic Shadow Distance MoveableLight" under Cascaded Shadow Maps - I have set my directional light to movable.

                      Comment


                        #26
                        please stop with the UE4 issues, this is the UE3 forum
                        Help me back! follow me on Twitter
                        Developer of Elium - Prison Escape

                        Comment

                        Working...
                        X