Announcement

Collapse
No announcement yet.

Project Crashes on start when Megascan 3d assets are in it

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Project Crashes on start when Megascan 3d assets are in it

    When i start my project i get this message, only deleting all 3d assets from megascan helps:
    LoginId:b0fb3d284c93f82d5627c2b00338381a
    EpicAccountId:f654555014104eb68ff1a7e096107f78

    Assertion failed: LODIndex >= 0 && LODIndex < 8 [File:/Build/++UE4/Sync/Engine/Source/Runtime/Engine/Private/StaticMesh.cpp] [Line: 1897]

    UE4Editor_Core
    UE4Editor_Core
    UE4Editor_Core
    UE4Editor_Core
    UE4Editor_Engine
    UE4Editor_Engine
    UE4Editor_Engine
    UE4Editor_Engine
    UE4Editor_Engine
    UE4Editor_CoreUObject
    UE4Editor_Engine
    UE4Editor_CoreUObject
    UE4Editor_CoreUObject
    UE4Editor_CoreUObject
    UE4Editor_CoreUObject
    UE4Editor_CoreUObject
    UE4Editor_UnrealEd
    UE4Editor_UnrealEd
    UE4Editor_UnrealEd
    UE4Editor_UnrealEd
    UE4Editor_UnrealEd
    UE4Editor_UnrealEd
    UE4Editor_UnrealEd
    UE4Editor_UnrealEd
    UE4Editor
    UE4Editor
    UE4Editor
    UE4Editor
    kernel32
    ntdll



    Does anyone know how to fix it ?

    #2
    Do you have uptdated your system? Which Windows-Version do you use? Seems like you have an issue with your system and UE4 is not working correct with Windows.
    Which version of UE4 do you use? Do you use the Bridge for the Megascans?

    Comment


      #3
      I had the same issue using Megascan assets. The way I fixed it was the following: In UE4, start double clicking on each Megascan static mesh in the Content/Megascan folder to view them in the editor window. If the mesh causes a crash, delete the folder containing the static mesh (you probably have to delete it directly from file explorer, deleting from within UE4 will cause it to crash). Do this for each Megascan static mesh, and once you've gone through and deleted all the corrupt assets, you should be able to load up the level. There probably is a more efficient way to find the corrupt assets, but this way worked for me.

      I unfortunately don't know what causes this issue, but it seems that Quixel is aware of this problem and will hopefully provide a fix soon: https://help.quixel.com/hc/en-us/com...sing-3d-asset-

      Comment

      Working...
      X