Announcement

Collapse
No announcement yet.

Why doesn't the "screen percentage" setting have any effect on supersampling for the rift anymore?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Why doesn't the "screen percentage" setting have any effect on supersampling for the rift anymore?

    I have noticed since getting the CV1 that in the post processing volume under misc the "screen percentage" setting no longer has any impact on the rift's supersampling settings. It used to work with the DK2.

    I have noticed this with the Vive also. It seems the only way I can "supersample" my project is to use Oculus Debug tool and force it that way.

    I don't want to have to expect other users to use the debug tool or the max render target .ini hack on SteamVR for my project. In addition I have noticed that the "HMD SP" and "HMD PD" commands seem to no longer do anything.

    So my question is: How in the heck do I supersample/increase the screen percentage for my project now without relying on outside "hacks"?

    I am really surprised no VR devs here have asked about this, and can't find any threads with instructions. It seems everyone complains about UE4 having a deferred renderer and that it's not good for VR, but with the added supersampling it really fixes a lot of the issues with blurriness and temporal AA! I just can't do it anymore without using outside utilities.

    I know it is possible in to do this still in UE4 because Raw Data has a slider for the screen percentage. My question is, where are they pulling this from, and why is screen percentage in the post processing volume now completely useless?
    Last edited by buckjohnston; 09-21-2016, 02:21 AM.

    #2
    There is a console command r.screenpercentage 100 which works. There was (or still) a problem with the screen percentage on post process volume that if you change the value over 100, the stereo mode gets broken. So for now the console commands works very well, you can use "Execute console command" node on event begin play.

    Comment


      #3
      I tried this console commend and see absolutely no difference in clarity. It still doesn't work in 4.14. The only way I can get things clearer on CV1 is to run the Oculus debug tool and force it that way. I'd rather distribute my demo with hard coded screen percentage that is forced and works, but it has no effect now when I force r.screenpercentage 130 in the level blurprint. There are some UE4 VR games that have a slider for screenpercentage so I know there has to be a way. Can anyone VR experts at Epic chime in?

      Comment


        #4
        This bug still present in 4.17 P3, maybe Epic can fix it, Tilt Brush has great scalling options, I hope Unreal Engine will be able to support it same as Unity.

        Comment

        Working...
        X