Announcement

Collapse
No announcement yet.

Decals and oculus rift problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Decals and oculus rift problem

    hI,

    I'm making some test with a scene to be displayed using Oculus Rift.
    The scene is filled with various decals: I've placed deferred decals using a material with DBuffer blend mode because with other blend modes decals are visible only if hit by direct lighting.
    Unfortunately, diplaying the scene with Oculus Rift, Dbuffer blend mode decals are visible only on one oculus eye.

    This is an issue or I'm making something wrong?

    I'm using unreal engine 4.1.1
    Please help me, I need a solution

    #2
    Originally posted by ciddi3d View Post
    hI,

    I'm making some test with a scene to be displayed using Oculus Rift.
    The scene is filled with various decals: I've placed deferred decals using a material with DBuffer blend mode because with other blend modes decals are visible only if hit by direct lighting.
    Unfortunately, diplaying the scene with Oculus Rift, Dbuffer blend mode decals are visible only on one oculus eye.

    This is an issue or I'm making something wrong?

    I'm using unreal engine 4.1.1
    Please help me, I need a solution
    You should really try to repro with 4.2.1. There were a number of one eye only stereo rendering fixes in the 4.2 release. If it still occurs in 4.2.1 file a bug report on AnswerHub. That is how I brought to Epic's attention the Beam Particle only drawing in one eye (which they fixed in 4.2, but also provided code to implement to fix it immediately).

    Comment


      #3
      Hi ciddi3d,

      As Sluisi mentioned, could yo utry reproducing this on 4.2.1 and let us know if it still occurs? There have been a lot of fixes since 4.1.1 and it may have been resolved already. If not, then please report it to the Bug Reports section of the answerhub. That will allow us to track the problem and assign a developer to investigate.
      Twitch /unrealalexander| Twitter @UnrealAlexander
      How to report a bug? | Installation & Setup issues?
      Call me to a thread by posting this: [MENTION]Alexander Paschall[/MENTION]

      Comment


        #4
        this is what I see when starting the game with oculus:
        Click image for larger version

Name:	oculus+decal01.jpg
Views:	1
Size:	434.5 KB
ID:	1052345

        these are deferred decal material settings:
        Click image for larger version

Name:	oculus+decal02.jpg
Views:	1
Size:	85.5 KB
ID:	1052346

        Comment


          #5
          Originally posted by ciddi3d View Post
          this is what I see when starting the game with oculus:
          [ATTACH=CONFIG]6201[/ATTACH]

          these are deferred decal material settings:
          [ATTACH=CONFIG]6202[/ATTACH]
          Is that using 4.2.1?

          Comment


            #6
            Yes. These shots are made using unreal engine 4.2.1.
            Also I've noticed that if I do not use DBuffer blend modes (i.e. using translucent blend mode) Decals work with oculus but aren't visibile inside shadows.
            Last edited by ciddi3d; 07-03-2014, 04:03 AM.

            Comment


              #7
              Hey ciddi3d,

              Thank you for posting your issue on the AnswerHub. I am currently looking into your issue and hope to help you with it as soon as possible. If you could provide a bit more information, on the AnswerHub post found here: https://answers.unrealengine.com/que...t-problem.html, I will be happy to further investigate and get a result back to.

              Thanks and have a great day!

              Comment

              Working...
              X