Announcement

Collapse
No announcement yet.

VR Expansion Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by mordentral View Post

    Please wrap that in code tags so that it boxes / scrolls.

    But yeah, you are using an older version of the template with a newer engine version (or upgrading it). Epic deprecated the ProjectPontOntoNavigation node in 4.16 (?I think, maybe it was 4.17).

    You literally just have to replace it with the new version that they added.
    aha, okay thanks for the info!

    Comment


      Originally posted by kusokuso1 View Post
      chaosyoshimage I pmed you a bit ago to help. It's cool you got it figured out though. Let me know what kind of tutorial you want and I can make a video on it.
      Yeah, I replied back, but you might've missed it. It was a Visitor Message reply instead of a PM, so that might be why. Thank you for offering! I feel I'm having trouble with really basic stuff that isn't worth making a tutorial for.

      I added the VRCharacter to my project and got rid of the default VRPawn, but I can't move the VRCharacter at all. I've set it as the Pawn for the project and everything. I've read something about adding movement to the character. Does the character not already have all of the stuff it needs for movement?

      Comment


        chaosyoshimage Yeah my bad, sorry, I don't even know what a Visitor Message is. lol I'll help you out in PM from here on out I think that would be best, so we don't clutter up this thread.

        If any of the videos I make are applicable to general usage of the plugin, I'll post back in this thread w/ a link to my forsaken YT channel...
        (I'll likely preface each w/ something like UE4 VRExpansion Plugin: How To ***)

        The SimpleVivePawnCharacter and VivePawnCharacter from the template are all ready to go. I'm assuming what you mean by "add" is that you created a new character of the VRCharacter class type. In that case it's not gonna do anything - just as a fresh non-vr character wouldn't. All the functionality is there, it's just that none of it is being used/accessed.

        I looked around and it doesn't appear like I have any Visitor messages. I'm not sure how to use that system.
        If you don't mind, let's continue in PM. Just click on my blue name -> Private Message near the top -> then fill out the stuff and send it.
        Last edited by kusokuso1; 12-20-2017, 09:00 PM.

        Comment


          I'm currently porting the plugin to the 4.19 branch (hasn't hit preview yet), this will be one of the longer ports so it may not be ready on day1 of the first preview but the end result should be some good changes.


          *Edit*
          Got the RPC changes ported over, also managed to sneak in another 6 bits saved over epics implementation, when walking around it will be 6 bits saved per send, and when falling it will be 38 bits per send (still 6 bits saved over their fortnite changes).

          Also the new method let me drop half of my RPCS, so the code base is cleaner and easier to maintain
          because of this I am probably going to back port the 4.19 movement replication changes to 4.18 as well after stability testing.
          Last edited by mordentral; 12-22-2017, 02:25 PM.


          Consider supporting me on patreon

          My Open source tools and plugins
          Advanced Sessions Plugin
          VR Expansion Plugin

          Comment


            I can't figure out how to do a grippable destructible mesh. I have been using the pre-made classes so far but they don't accept destructible meshes. I tried remaking and copying the stuff from the pickup cube blueprint from the demo level but the resulting destructible mesh just rolls on the ground in the direction of the controller when I try to grab it.

            Comment


              Hi mordentral
              I'm trying again with the plugin since I've moved to UE4.18.2
              I downloaded what I need but currently I'm unable to build the VR Plugin Example project in VS2017.
              First I tried to just open the project, but it keep saying that"The following modules are missing or built with a different engine version"
              VRExpPluginExample.dll
              AdvancedSessions.dll
              AdvancedSteamSessions.dll
              OpenVRExpansionPlugin.dll
              VRExpansionPlugin.dll

              If I choose yes I have a "VEExpPluginExample could not be compiled. Try rebuilding from source manually"


              Anyway below you'll find what happens in VS2017


               
              Spoiler




              I also tried to basically copy the Content folder from the Example scene into a 4.18.2 scene with the Plugin installed.
              I'm able to open the HMD Locomotion Map, but as soon as I start the PIE it says that the 3d menu is broken, and I'm literally unable to use the controllers.

              So...yeah, VS is kicking me in the nuts and I have no idea how to solve this

              My idea was to use the example scene as the starting point to add my own stuff, so without it I'm kinda of lost

              A bit of help will be really appreciated!
              ENTER REALITY

              VR Solutions

              Contact us for more informations

              Comment


                Originally posted by Enter Reality View Post
                Hi mordentral
                I'm trying again with the plugin since I've moved to UE4.18.2
                I downloaded what I need but currently I'm unable to build the VR Plugin Example project in VS2017.
                First I tried to just open the project, but it keep saying that"The following modules are missing or built with a different engine version"
                VRExpPluginExample.dll
                AdvancedSessions.dll
                AdvancedSteamSessions.dll
                OpenVRExpansionPlugin.dll
                VRExpansionPlugin.dll

                If I choose yes I have a "VEExpPluginExample could not be compiled. Try rebuilding from source manually"


                Anyway below you'll find what happens in VS2017


                I also tried to basically copy the Content folder from the Example scene into a 4.18.2 scene with the Plugin installed.
                I'm able to open the HMD Locomotion Map, but as soon as I start the PIE it says that the 3d menu is broken, and I'm literally unable to use the controllers.

                So...yeah, VS is kicking me in the nuts and I have no idea how to solve this

                My idea was to use the example scene as the starting point to add my own stuff, so without it I'm kinda of lost

                A bit of help will be really appreciated!
                Looks like you didn't install the c++ module for VS2017?

                You'll also need to install the windows 8 package during install as it is also required for UE4

                The pre-packaged binaries should work for you, but you still want to fix your the VS2017 install.



                Consider supporting me on patreon

                My Open source tools and plugins
                Advanced Sessions Plugin
                VR Expansion Plugin

                Comment


                  Originally posted by mordentral View Post

                  Looks like you didn't install the c++ module for VS2017?

                  You'll also need to install the windows 8 package during install as it is also required for UE4

                  The pre-packaged binaries should work for you, but you still want to fix your the VS2017 install.
                  Thank you for the tip!

                  I checked and looks like that the C++ modules are installed...and it's odd, since a couple of days ago I built 4.18.1 from source without any errors.

                  I'm reinstalling VS2017 from scratch and hopefully I'll solve the issue.

                  The prebuilt plugin, once I followed the guide, is installed and I have no errors when launching the project, but I will just use the example scene to built my projects on top of it
                  ENTER REALITY

                  VR Solutions

                  Contact us for more informations

                  Comment


                    Hi and merry christmas

                    I tried a couple of times to reinstall VS2017, but I still have no luck ( basically the same error and before ).
                    I'm not very familiar with VS2017, but looking around to see where the C++ modules can be installed, I found this page which shows how to install them.
                    Unfortunately the "Standard Library Modules" within the "Desktop Development with C++" is not there, so I guess that they changed the name or something...anyway this is the list of what I installed with VS2017
                    Click image for larger version

Name:	01.JPG
Views:	4
Size:	54.8 KB
ID:	1404593
                    Click image for larger version

Name:	02.JPG
Views:	5
Size:	50.5 KB
ID:	1404594

                    I also tried to run VS2017 as Admin ( since I noticed a couple of "You don't have the rights" errors, but stil no luck.
                    I also tried to remove VS2017 and re-install VS2015 with ALL the components in the list, but then again not luck, I can't build the project.

                    Sorry to bother again, but can someone please help me with this?

                    Cheers

                    Nicolas
                    ENTER REALITY

                    VR Solutions

                    Contact us for more informations

                    Comment


                      Originally posted by Enter Reality View Post
                      Hi and merry christmas

                      I tried a couple of times to reinstall VS2017, but I still have no luck ( basically the same error and before ).
                      I'm not very familiar with VS2017, but looking around to see where the C++ modules can be installed, I found this page which shows how to install them.
                      Unfortunately the "Standard Library Modules" within the "Desktop Development with C++" is not there, so I guess that they changed the name or something...anyway this is the list of what I installed with VS2017
                      I also tried to run VS2017 as Admin ( since I noticed a couple of "You don't have the rights" errors, but stil no luck.
                      I also tried to remove VS2017 and re-install VS2015 with ALL the components in the list, but then again not luck, I can't build the project.

                      Sorry to bother again, but can someone please help me with this?

                      Cheers

                      Nicolas
                      When did you delete ALL "Intermediate" and "binary" folders in the project? Both the projects base directory and each plugins directory will have them. I am seeing a lot of stale .GEN file errors in that error list. Some times the engine doesn't correctly decide that it needs to re-build binaries and tries to use old/stale generated files.

                      Try deleting all intermediate folders, regenerating the project files (right click on .uproject), and then compile.

                      Its a common problem with any source project that uses plugins AFAIK.


                      Consider supporting me on patreon

                      My Open source tools and plugins
                      Advanced Sessions Plugin
                      VR Expansion Plugin

                      Comment


                        Originally posted by mordentral View Post

                        When did you delete ALL "Intermediate" and "binary" folders in the project? Both the projects base directory and each plugins directory will have them. I am seeing a lot of stale .GEN file errors in that error list. Some times the engine doesn't correctly decide that it needs to re-build binaries and tries to use old/stale generated files.

                        Try deleting all intermediate folders, regenerating the project files (right click on .uproject), and then compile.

                        Its a common problem with any source project that uses plugins AFAIK.
                        Thanks for the reply.

                        As soon as I unzipped the file the Intermediate folder wasn't there ( nor the binary ), so I just right click the VRExpPluginExample.uproject and choose Generate Visual Studio Project.
                        After that the Intermediate folder and the .sln was created, so I opened the Visual Studio project and chose Build Solution.

                        The build always fail...at this point I'm thinking that there is something wrong with my VS, since it fails with both 2017 and 2015....I looked back a while ago when I first tried the plugin, and the errors I got are basically the same.
                        So frustrating to see that it fails but no idea how to solve that

                        Question: If I get a built 4.18.2 version of the VRExpPluginExample, I should be able to use it as a standard UE4 project, right? So no need for me to use VS at all, correct?
                        ENTER REALITY

                        VR Solutions

                        Contact us for more informations

                        Comment


                          Originally posted by Enter Reality View Post

                          Thanks for the reply.

                          As soon as I unzipped the file the Intermediate folder wasn't there ( nor the binary ), so I just right click the VRExpPluginExample.uproject and choose Generate Visual Studio Project.
                          After that the Intermediate folder and the .sln was created, so I opened the Visual Studio project and chose Build Solution.

                          The build always fail...at this point I'm thinking that there is something wrong with my VS, since it fails with both 2017 and 2015....I looked back a while ago when I first tried the plugin, and the errors I got are basically the same.
                          So frustrating to see that it fails but no idea how to solve that

                          Question: If I get a built 4.18.2 version of the VRExpPluginExample, I should be able to use it as a standard UE4 project, right? So no need for me to use VS at all, correct?
                          Yes, but I still suggest that people use it with the compiler when possible so that they can migrate without a specific pre-built package.


                          Consider supporting me on patreon

                          My Open source tools and plugins
                          Advanced Sessions Plugin
                          VR Expansion Plugin

                          Comment


                            Originally posted by mordentral View Post

                            Yes, but I still suggest that people use it with the compiler when possible so that they can migrate without a specific pre-built package.
                            Thanks again for the advice.

                            I tried again to build the example scene onto another pc ( by also reducing the folder name length and put everything on the desktop ) and the build still fails, but I can see some progress overall ( I'm not having the "can't move bla bla" error )

                            Here is a list of what's happening

                             
                            Spoiler


                            Well, unless someone is willing to upload an already built 4.18.2 version of the example scene ( wink wink ), unfortunately I'm giving up on this plugin
                            I was really looking forward to use it, especially for the multiplayer setup already working

                            Thanks again fore the help and for developing this plugin for the community
                            ENTER REALITY

                            VR Solutions

                            Contact us for more informations

                            Comment


                              Originally posted by Enter Reality View Post

                              Thanks again for the advice.

                              I tried again to build the example scene onto another pc ( by also reducing the folder name length and put everything on the desktop ) and the build still fails, but I can see some progress overall ( I'm not having the "can't move bla bla" error )

                              Here is a list of what's happening

                              Well, unless someone is willing to upload an already built 4.18.2 version of the example scene ( wink wink ), unfortunately I'm giving up on this plugin
                              I was really looking forward to use it, especially for the multiplayer setup already working

                              Thanks again fore the help and for developing this plugin for the community
                              The 4.18.2 pre-compiled binaries should work with it...? That is what they are for, they are pre-built plugin files.

                              Regardless, yeah....I don't know why your VS installation is screwed up.


                              Consider supporting me on patreon

                              My Open source tools and plugins
                              Advanced Sessions Plugin
                              VR Expansion Plugin

                              Comment


                                I can't grab a point of the skeleton. This Can support to grab softbody.

                                Comment

                                Working...
                                X