Announcement

Collapse
No announcement yet.

Error Packaging Project

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [GEAR VR] Error Packaging Project

    I keep getting an error when packaging my project for Android.

    I have reinstalled the SDK, NDK, JDK (the whole of AndroidCodeWorks). I've also tried building on different API versions keeping the NDK API at 'matchndk'. I read online other people having the same problem and installing Visual Studio helped them so I installed VS Express 2013 and that also didn't seem to do the trick.

    I've attached the log from the packaging error.

    Not to sure what's causing the problem. I can build in Android Studio.
    Attached Files

    #2
    I should mention, I am using Unreal Engine 4.12.5.

    I'm not to sure if there are problems with that?

    I haven't tried another engine version just yet.

    Comment


      #3
      Still looking for help on this

      Comment


        #4
        I've just read somewhere that when installing CodeWorks for the Android stuff you need to install NSight for Visual Studio, I've tried to do this but it tells me that it won't work on an express edition for Visual Studio. Does this mean I need to buy Visual Studio. I may try out Visual Studio 2015 Community as I have Visual Studio 2013 Express installed at the moment.
        Last edited by SlipperyBrick; 07-12-2016, 10:00 AM.

        Comment


          #5
          VS 2015 Community should work. I've looked at your log but I don't see anything obvious. I'd recommend creating an AnswerHub post and include the full log.

          Comment


            #6
            Hey Chris,

            That's great no problem. I'll create post on AnswerHub if VS 2015 Community doesn't work for me.

            Comment


              #7
              I have followed all the instructions mentioned in this AnswerHub post: https://answers.unrealengine.com/que...ml?sort=oldest

              I have uninstalled VS Express 2013 and installed VS Community 2015, I've choosen the 'Full' installation preset within the module manager for AndroidCodeWorks when it gets to the stage of installing NSight I get the following error:



              It seems that VS Community 2015 and any 'Express' editions of VS are not supported and NSight seems to be a requirement for being able to develop for Android within Unreal Engine 4.

              Any help on this would be appreciated, confirmation on whether NSight is needed or whether it's not would be great. Otherwise it appears that buying VS Professional is a requirement to be able to develop for Android in Unreal Engine 4
              Attached Files

              Comment


                #8
                Just reporting back to say given the issues I've had I have taken your advice Chris and posted on the AnswerHub.

                Looking forward to a reply and hopefully a solution to the problem

                Comment

                Working...
                X