Announcement

Collapse
No announcement yet.

4.12 VR Build

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    4.12 VR Build

    I have built my VR project out, but whenever I open the game it just shows black screen and closes. It works fine in the editor. In my level blueprint I have set console command to "Stereo On" which always worked in 4.11. Has there been made some changes to that on 4.12?

    It does the same for a new project with only starter content

    However after trying to open it a couple of times it may randomly load. Has anyone else encountered this problem?
    Last edited by johnpre; 06-06-2016, 05:26 PM.

    #2
    Same problem here with Oculus DK2. Can't seem to find a solution. Best luck for me is to close the Oculus software, then launch my game. Oculus software will relaunch then sometime the game launches, sometimes the game shows black then closes. Odd thing is my load level does not call 'stereo on'. It is just a menu screen that allows you to select with or without VR. That menu then directs you to another level that calls 'stereo on'. So the problem is not with 'stereo on'... but I have no idea what else it could be.

    Comment


      #3
      Yep, this is a thread i want to be subscribed to ).
      And as long as we are on the subject of the dk2, can anyone shed some light as to what we need to have installed on the computer so the VR game works for our clients or any other testers for that matter.

      Comment


        #4
        Good to hear that its not only me.

        [MENTION=305629]dansuciu[/MENTION] You need the Oculus software (https://www.oculus.com/en-us/setup/) and in settings->general allow for "Unknown Sources" that works for me.

        Comment


          #5
          Same problem to me.
          VR build work in 4.11 but don,t work in 4.12.
          In editor both work fine.

          I use a Dk2 and W10.
          [SOLVED]

          Click image for larger version

Name:	73bfcb911d3842529fcba49773cdde40.png
Views:	2
Size:	157.2 KB
ID:	1107942

          This work for me.

          Press Alt+Enter to go fullscreen mode.

          Work in Launch mode and Compiled game, but don't work in standalone mode.

          Cheers.
          Last edited by pery77; 06-09-2016, 06:26 AM.

          Comment


            #6
            This issue is recognized by EPIC, it has been given a bug report #UE-31719 hopefully it will be fixed soon.

            Comment


              #7
              The only way to go into VR mode in 4.12+ is with "stereo on" in console or launching your game with -vr. CV1 has a proximity sensor and will not start rendering to HMD unless you have it on (or have your finger infront of proxmity sensor)

              Make sure you have "enable unknown sources" in the oculus home app (under settings -> general)
              Twitter - @TheKRushin

              Feel free to ask questions and come learn to be an #UnrealDev

              How to report a Bug

              Comment


                #8
                Great to see both -vr and "stereo on" make it work, but is there a way to get VR to work in 4.12+ and have the primary monitor display a single image (instead of stereo?). Thanks!
                Alex Coulombe
                Creative Director
                Agile Lens: Immersive Design
                New York City
                www.agilelens.com

                Comment


                  #9
                  Originally posted by KRushin View Post
                  The only way to go into VR mode in 4.12+ is with "stereo on" in console or launching your game with -vr. CV1 has a proximity sensor and will not start rendering to HMD unless you have it on (or have your finger infront of proxmity sensor)

                  Make sure you have "enable unknown sources" in the oculus home app (under settings -> general)
                  This doesnt work in 4.12 anymore its working fine in 4.11. I am beginning to think that its only a DK2 problem.. can other people confirm this? Create a blank project in 4.12 set it to "stereo on" and see what happens. DK2 and CV1.
                  Last edited by johnpre; 06-16-2016, 05:02 PM.

                  Comment


                    #10
                    Did you uninstall all previous SDK's like Oculus 0.8 and then install oculus home(https://www.oculus.com/en-us/setup/)?
                    Twitter - @TheKRushin

                    Feel free to ask questions and come learn to be an #UnrealDev

                    How to report a Bug

                    Comment


                      #11
                      Yes I am running Oculus home 1.4..

                      Comment


                        #12
                        sorry don't know what to tell you, DK2/CV1 work for me and my Home PC (win10) and work pc (win 7) :-/ perhaps try to find the logs and see if you are getting errors in your UE4 logs? They are located in /saved/logs/
                        Twitter - @TheKRushin

                        Feel free to ask questions and come learn to be an #UnrealDev

                        How to report a Bug

                        Comment


                          #13
                          Originally posted by KRushin View Post
                          sorry don't know what to tell you, DK2/CV1 work for me and my Home PC (win10) and work pc (win 7) :-/ perhaps try to find the logs and see if you are getting errors in your UE4 logs? They are located in /saved/logs/
                          Having the same problem right now with 4.12.3. Had to disable SteamVR-Plugin. But performance is absolutely horrible, also the startup position of the player isn't the same as before.
                          Last edited by spyro; 06-17-2016, 12:51 PM.

                          Comment


                            #14
                            Since 4.12 packaged game for Vive closes right after launch if SteamVR service is not running. Don't know about Oculus.
                            Marketplace: Vive Mocap Kit / Fingers Solver / VR IK Body Solver / Subtitles to LipSync / Dialogue System with Character Animation
                            And random stuff at Youtube

                            Comment


                              #15
                              Same issue here. Can't get a packaged game to run on the dk2...4.12.3. VR preview in editor works fine.

                              Comment

                              Working...
                              X