Announcement

Collapse
No announcement yet.

Latency in Camera translation on the Vive.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Latency in Camera translation on the Vive.

    Hi I noticed considerable latency in camera translation when using the Vive both in Pie and in pure game. Tested this in 4.11 and 4.12 on bot the regular and beta branch of SteamVR.

    This latency seems to persist for all tick groups for the camera (component). I am using the SteamVR overlay just to visualise it as the controllers are just resting on a surface. The problem is the latency, not the discrepancy per se, that is just a side effect.
    The issue is not there in the VR Editor in 4.12 and as I discovered later in some specific games like The Brookhaven Experiment either. But most UE demos seem to have it.

    The issue seems not to be present on the Rift.

    Any advice on tracking down the cause would be much appreciated!

    This Answerhub post seems to be dealign with the same issue: https://answers.unrealengine.com/que...2-preview.html



    *Edit* Upon further investigation I narrowed it down to having an active camera component in the pawn. If i disable it the latency vanishes.
    Last edited by AtsK; 06-04-2016, 11:41 AM.

    #2
    I was able to reproduce the issue, and good news is the fix is already in 4.12! The issue is fixed in github (the fix is fairly straightforward to apply to 4.11 manually). The issue was logged as UE-31687


    https://github.com/EpicGames/UnrealE...0d141513a44797


    The fix won't make it to the binary version until 4.12.2, so if you want the fix sooner than later just head over to github
    Last edited by KRushin; 06-07-2016, 07:49 AM.
    Twitter - @TheKRushin

    Feel free to ask questions and come learn to be an #UnrealDev

    How to report a Bug

    Comment

    Working...
    X