Announcement

Collapse
No announcement yet.

[gearVR] Desperate for help: black screen builds!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [gearVR] Desperate for help: black screen builds!

    Hi all!

    I'm becoming desperate so any help is SUPER-appreciated!!! I'm a good coder, been developing with CoronaSDK for a couple of years, and a professional 3D artist, so I've got a good basic skillset. Learning Unreal is going well, but one simple thing is frustrating me beyond belief!!!

    I can not seem to get ANY of my own stuff to run on my gearVR headset with a Samsung Galaxy S7. It's not my dev-setup, because packaging the 1st Person Shooter template runs great on my gearVR, but somehow ALL I get is a black screen, with the two virtual joysticks on it.

    I'll try to do a thorough description here:
    - As said before, the 1st Person Shooter template works like a charm, so all SDKs are in place, and I use the same settings for Android SDK, NDK, Apache etc...
    - Packaging from a Retina MacBook Pro, so OSX.
    - Tried building my lights, used static lights, used unlit materials: I tried everything to rule out that I wasn't just see darkness, but still, no dice!
    - I put in an AmbientSound actor as well to check if I had sound, but I'm not hearing anything either.
    - right now my scene is just about empty: a floor cube, two static pointlights and six cubes in an unlit, self emissive material (and a playerstart).
    - I'm doing all the necessary gearVR things as far as I can see (and the app does run on gearVR, but it only shows the black screen, two virtual joysticks and no sound). SDK levels set right, plugins set right, oculussig set right, deploy to gearVR set right..

    Could it be because I don't have a pawn, character or all that in my scene? When I run it in the editor a lot of these things are auto-created. Is this not happening when runnning on gearVR?

    Or is something else the problem?

    I would really, really LOVE to get some help here, because I'm enjoying everything in Unreal, seeing things work and move, but somehow even the simplest build to gearVR fails, and it's really bugging me. Going crazy here!!!

    #2
    Ah, I forgot to mention:

    Running 4.11.2 here, on OSX. Also, when I uncheck that "gearVR manifest" thingy, I get the same thing: two virtual joysticks onscreen, no sound, black rest of screen. The joysticks "work", as does the splash screen.

    Comment


      #3
      Ok I'm gonna bet you have a new level yes with a unique name yes?

      And when you run in PIE it works right but when ya build empty...

      ok if this is the case with a custom level and since rereading your post, i see no mention of setting this:

      open project settings,

      and under Maps and Modes you need to set your Default Maps and Default Modes and Game Instance...

      Sorry if this does not help but it sounds like something I did and kinda sounds like same pattern with blank start.

      Comment


        #4
        Hi WilliamHooper,

        Thank you thank you thank you a million times!!! This fixed my issues! If you're ever in Belgium, I'll buy you a beer!

        Comment


          #5
          Awesome... and if I am I'll take ya up on that Beer.

          Comment

          Working...
          X