Announcement

Collapse
No announcement yet.

How do you actually enable VR in a packaged project? Enabled HMD isn't working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    I'm starting to seriously get worried my Rift is busted or something.. is it not being detected properly by unreal?

    Can someone comfirm that in a new project in 4.12 if they do enable HMD it works?

    VR preview works for me like I said but otherwise every single VR command does nothing. I'm ready to distribute my project but I can't because of this..

    Edit: If I package my project and add -VR to the shortcut, then it works.. this is kinda silly though, can I not do this in game? I don't want to have to include a shortcut and an EXE and get people confused.. My entire purpose here is letting the player manage this in-game in an entirely intuitive manner.

    With -VR all the VR commands work. Without it, they don't. Is there no way I can default -VR, or no way I can add it with blueprints in game? No way I can force it? No way I can do -VR console command? (stereo on / hmd enable ONLY work when it's ALREADY in VR mode.. IE VR preview or adding -VR command line. I NEED This to be accessible in game like it seems it should be)
    Last edited by Pinworm; 05-25-2016, 09:23 PM.

    Comment


      #17
      Pinworm, I just tested with Unreal 4.12 and it works fine?

      1) New project
      2) Simple map with one object.
      3) Run the game (non VR, not through editor)
      4) Open console and write "stereo on" and voila.. I'm in VR, using a Rift CV1.

      Does that not work for you? What HMD are you using? What version of Unreal?
      Programmer at Klang Games | Ex-CCP (EVE Valkyrie / Sparc) | @SiggiGG
      Check out my procedural mesh examples

      Comment


        #18
        Originally posted by SiggiG View Post
        Pinworm, I just tested with Unreal 4.12 and it works fine?

        1) New project
        2) Simple map with one object.
        3) Run the game (non VR, not through editor)
        4) Open console and write "stereo on" and voila.. I'm in VR, using a Rift CV1.

        Does that not work for you? What HMD are you using? What version of Unreal?
        Okay, this works once packaged.. The issue is this doesn't seem to work in "launch stand-alone game" through the editor. I was using that and assuming it wouldn't work in a packaged game, but trying it with a packaged game it works. Just need to keep that in mind (seems like a bug?)

        Thanks for helping me debug

        Comment


          #19
          No worries, glad to help
          Programmer at Klang Games | Ex-CCP (EVE Valkyrie / Sparc) | @SiggiGG
          Check out my procedural mesh examples

          Comment


            #20
            Just a heads up to anyone else stumbling into this thread:

            There is a new way to get your packaged builds to start in VR. It's a very simple setting you have to enable:

            Edit -> Project Settings -> Description (under Project) -> Settings (very bottom) -> "Start in VR" (off by default)

            Comment


              #21
              Originally posted by Pinworm View Post
              Okay, this works once packaged.. The issue is this doesn't seem to work in "launch stand-alone game" through the editor. I was using that and assuming it wouldn't work in a packaged game, but trying it with a packaged game it works. Just need to keep that in mind (seems like a bug?)

              Thanks for helping me debug
              It's not a bug, and it's very useful for debug purposes! Testing with a VR pawn at all times gets tedious, especially if you need to glance over printed values during play. Stereo on always works in a packaged game.

              Comment


                #22
                Edit -> Project Settings -> Description (under Project) -> Settings (very bottom) -> "Start in VR" (off by default)
                worked perfectly to get the packaged app running, thanks Slayemin. I saw that check box but thought it was for starting the editor in "VR Mode".
                To me it would have been more intuitive to put the check box under Project Settings -> Packaging -> "Start in VR", but I'm sure that they had their reasons for putting it there...

                Comment

                Working...
                X