Announcement

Collapse
No announcement yet.

FMOD 3d sound not playing trough Oculus Rift CV1 headset??

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    FMOD 3d sound not playing trough Oculus Rift CV1 headset??

    First: I cannot use the Oculus Sound plugin otherwise the packaging will crash. 3d sound with that Oculus plugin works very good so it is sad i can't use the Oculus plugin in UE4. So i was forced to get into FMOD because 3d sound should work trough that programm. Now i have FMOD running and created the first 3d sound FMOD file for in UE4.

    But a surprise and new frustration; The sound is playing trough my sound installation - not the Oculus Rift CV1 headset!! Why is this? I did set the FMOD prefferences to Rift Audio but still the sound will not use the Oculus Headset. And yes i did Build my sound, saved it, rebuild it multiple times.


    Hope someone can help here, it feels like 3d sound is underestimated where it is hard to find any information about VR and 3d sound, also because official UE4 Vr audio plugins seem to be not updated for a long time? Hpe to get some insight and support.

    #2
    I have found the solution for this problem, if it is a solution? I found this post about thesame problem where audio in some games and apps in Oculus Store also do not play trough the oculus headset;l, see;

    https://forums.oculus.com/vip/discus...-on-headphones


    It seems that when using the FMOD assets & plugin in your project, that your oculus headset has to be set in the windows sound settings to "main speakers". this means the oculus headset will top every other sound channel output and be highest in hierarchy.

    The solution is simple, you need to setup this for making your rift work well with some applications, it seems.

    Comment

    Working...
    X