Announcement

Collapse
No announcement yet.

packaged game looks different than in preview

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    packaged game looks different than in preview

    I was talking about this in a previous post but figured I'd start a new one because this is really stumping me.

    When I package my game it looks pretty different than it does in preview. I have widget text above my characters and in the built game it is hard to read. Also in the built game things are not quite as clear, it has a warmer feel and in the distance when there is animation there are artifacts in the movement.

    Here is my scalability settings in the editor and my level blueprint:
    Click image for larger version

Name:	scale1.jpg
Views:	1
Size:	23.0 KB
ID:	1166097
    Click image for larger version

Name:	scale2.jpg
Views:	1
Size:	101.0 KB
ID:	1166098

    Here is an example of what I mean. The top image is from the editor and the bottom is from the build. You can see the text is illegible in the build version and it has warmer colors.
    Any ideas what I could be doing wrong? I also have a post processing volume but all I have tweaked is a little bit of the gamma and saturation. Thanks for any help!!

    Click image for larger version

Name:	scale4.jpg
Views:	1
Size:	109.7 KB
ID:	1166099
    Click image for larger version

Name:	scale3.jpg
Views:	1
Size:	107.5 KB
ID:	1166100
    Last edited by jeremycouillard; 10-31-2015, 03:50 PM.

    #2
    Im not sure whats going on there but it almost looks like two different types of AA are being used there(which makes no sense).
    P.S "hmd sp" and "r.screenpercentage" do the same thing. looking at your blueprint all you are doing is changing the SP to 120 and then changing the SP to 100.

    Comment


      #3
      Thanks for the help. I fixed the blueprint (also had a typo :-P) turned on TemporalAA in the ppv...also made sure to put motion blur at 0. That sort of seems like maybe it helped. But the most annoying thing is that the 3d widgets above the actors are so blurry in the build but super crisp in the editor. Any ideas?

      Comment


        #4
        Are you saying that there was a difference in AA between the two images?
        I also didnt realise that the text was a 3d widgit. It may be a known bug between the two(I thought the text was just a textrenderer).
        I have a demo project which illustrate the pro's and cons of the two method here https://forums.unrealengine.com/show...osite-Textures
        Last edited by Opamp77; 10-31-2015, 04:50 PM.

        Comment


          #5
          thanks for the help. it seems to me (but it's hard to tell) that the packaged game was using fxaa and the preview was using temporal. once i specified in the ppv to use temporal they both seemed a little more similar....but yes the widget still looks really bad in the packaged game. also the preview just seems brighter and more clear....are there any other settings I could mess with? thanks for

          Comment

          Working...
          X