Announcement

Collapse
No announcement yet.

Health and safety warning pops up every level

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Health and safety warning pops up every level

    Hi I'm hoping someone found a solution to this. I'm using Unreal engine 4 and in the game I'm making I have to set a console command fullscreen to make sure that the game and level starts in the rift but for some reason at the start of each level so when the game loads level 2,3,4 and so on the health and safety warning pops up for the player. Has anyone come across this issue and know a solution to stop it popping up?

    #2
    Read all about it here:
    https://forums.oculus.com/viewtopic....safety#p260346

    This is how mine looks (see path at the bottom):


    EDIT: re-reading your question I don't know how you can disable it for other players, sorry.

    Comment


      #3
      Ya I'm not looking to disable it for other players. Its fine to come up at the start of the game but for it to pop up at the start of every new level is a pain in the ***. Its almost as each new level starts, unreal resets the game. I mean the level loads fine but say I had the game in full screen the next level resets the full screen and would load in that default small window for some reason.

      Comment


        #4
        Not sure why thats happening. I recenently had an issue with a 4.6 project that I upgraded to 4.9.1. And with a shipping build the HSW warning would show up every time the screen percentage was changed. This only ever happened on the first run when there where no settings in the users/username/Appdata folder. Afther that was present additional runs where fine but deleting the settings and running again would bring the issue back for the first launch. I somehow managed to fix this by doing a full rebuild for shipping.

        failing that try "stereo on" rarther than "fullscreen".

        Comment


          #5
          I think its a problem with the way unreal package the game. Each packaged game is by default designed to start in windowed mode and even if you alt enter when each new level starts it it goes back to windowed mode. Even using the command fullscreen it still starts the game in windowed mode and quickly goes to full screen. I'll try what you said, waiting on a convex decomposition to finish processing on a mesh (takes forever lol) now only if there was a setting I could switch that has the packaged game start in full window instead of the default window mode that would solve the problem.

          Comment


            #6
            Just to be clear you are only calling fullscreen once?
            The reason I ask is that "fullscreen" is a toggle cmd(it will go to a window if allready fullscreen) which is why I suggested using stereo on instead.
            If your calling multiple times then the HSW will pop up each time you go to fullscreen.
            Where abouts are you calling this and how are you loading levels?

            Comment


              #7
              I use the player character to load fullscreen on a eventbeginplay just once. I tried putting it in the gamemode but it went out of oculus/fullscreen mode when a new level loaded.

              Click image for larger version

Name:	Loadlevel.JPG
Views:	1
Size:	154.0 KB
ID:	1092241

              Comment


                #8
                if your not using streaming levels then your player character is probably being destroyed then recreated upon each level load. which mean beginplay will be called again on the new object. You could check this by puting a print string at the begining of the beginplay.

                *edit
                Im guessing the same for gamemode as well.
                best option would be to open the console and see how many times "fullscreen" has been called after a level load.
                Last edited by Opamp77; 10-29-2015, 09:49 PM.

                Comment


                  #9
                  Just packaged a game with "stereo on" instead of "fullscreen" and it works like a dream. Thanks Opamp77

                  Comment

                  Working...
                  X