Announcement

Collapse
No announcement yet.

UE4.9.1 does not recognise Rift with 0.6.0.1, and has game breaking performance with 0.7.0.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Just did a test, upgraded and packaged my project in 4.10 preview 4, and still the same problems, it's unusable in the rift, there's judder everywhere.

    Leave a comment:


  • replied
    Update: still bad performance with runtime 0.8 and NV driver 358.78.

    Leave a comment:


  • replied
    same issue with me

    Leave a comment:


  • replied
    No issues with my little project so far...

    I feel special.

    Leave a comment:


  • replied
    Why isn't anyone using the GPU profiler to find the smoking gun?

    Leave a comment:


  • replied
    Originally posted by sHTiF View Post
    The 4.9.2 Unreal Editor is basically unusable for VR development I have 0.7 SDK with latest NVidia drivers 356.04 on a GTX 970 and I can't even run a simple FPS example without judder. Since Unity is running smoothly, and all the other Oculus available games demos as well I think its obvious there is some problem with UE4 itself unfortunately.
    In my case, disabling AO restored some of the lost FPS, but not enough, and it's nowhere near to how stable FPS-wise my project used to be. I have to agree, 4.9.2 is useless for VR development as it currently is, and I can only hope that there'll be a solution in one of the next point revisions.

    Leave a comment:


  • replied
    The 4.9.2 Unreal Editor is basically unusable for VR development I have 0.7 SDK with latest NVidia drivers 356.04 on a GTX 970 and I can't even run a simple FPS example without judder. Since Unity is running smoothly, and all the other Oculus available games demos as well I think its obvious there is some problem with UE4 itself unfortunately.

    Leave a comment:


  • replied
    I faced the same issues here, 4.9.1/2 and 0.7.0.0 were significantly worse for VR. Juddering was very obvious especially when turning the head side to side.

    Disabling AO helped ms alot, thanks for the tip. I have yet to test the project in VR after disabling AO though. Still, is there a problem inherent with 4.9.1 and 0.7.0.0?
    I made a nvdia update as well when I upgraded to 4.9.1, as VR preview just wouldn't launch and alt enter crashes the UE editor. At the point of time, I wasn't sure if the problem was 0.6.0.1 or my nvdia drivers so I updated both.

    Leave a comment:


  • replied
    Originally posted by Sam Deiter View Post
    Did you read the official Oculus Blog post I linked? In there they clearly state that the recommended specs for development and users will be around the following for the rift.

    NVIDIA GTX 970 / AMD 290 equivalent or greater
    Intel i5-4590 equivalent or greater
    8GB+ RAM
    Compatible HDMI 1.3 video output
    2x USB 3.0 ports
    Windows 7 SP1 or newer

    While these are only recommended specs they are official specifications from Oculus stating which hardware you should be targeting and using for development. With that said your Nvidia 680 GPU is just not powerful enough for rendering things in VR without ensuring that what you are making is not overly complex and extremely simple. I just tested the Vehicle Game(Sorry I missed that part) with a Vive and a DK2 using an Nvidia 980 GPU and in each instance when disabling AO made them run at frame.
    This is wrong, I think you've missed the point of what Oculus' recommended specifications are relevant to, and why they're not relevant to this issue.

    Also, 680 is still supported under 0.7: https://forums.oculus.com/viewtopic.php?f=34&t=26029 so should suffer NO performance issues compared to older Runtimes.

    Reminder: GPUs below Nvidia GTX 600 series or AMD Radeon HD 7000 series are not supported.

    Originally posted by Sam Deiter View Post
    I never stated that we (Epic) we're dropping support for certain video cards so I am not sure where you got this from.
    I said IF the regression is only affecting certain cards, which you're implying by stating that my hardware might be the issue. If my hardware is the issue, what this implies is that somewhere between 4.9.0 and 4.9.1 OR 0.6.0.1 and 0.7.0.0, something has been dropped for certain hardware, and not for other hardware. This would mean that support somewhere is being dropped.

    Originally posted by Sam Deiter View Post
    If this is something that I lead you to believe then I am sorry about that. What I was trying to express to you is that with your current GPU (Nvidia 680) you're going to find it hard to run things at frame right out of the box with UE4 as even Oculus has stated that you are going to need at least a Nvidia 970 / AMD 290 equivalent or greater to get the full proper VR experience. Finally have you tried the Showdown VR demo yet? If so does that run at frame for you? That would be the best test to see if your GPU is up to the task of VR as that runs at frame on all the devices I test with and is a fairly good example of how complex you can expect VR scenes to be. Give that a try and let me know what your performance is.
    Showdown runs with no issues with 0.6.0.1 and UE4.9.0, even with some settings enabled that aren't enabled by default (SSR), and is very well performing on a GTX680. Showdown also runs on Sony's PlaystationVR, FYI which according to you is also "under spec for VR" unless Playstation 4's have all been secretly installed with GTX970s.


    Edit: I apologize for that sarcastic comment, but here's my point: VR does not have a minimum specification, what does is a specific hardware peripheral that is not released yet that has nothing to do with the Rift DK2 or development hardware. Kepler architecture is still supported by NVIDIA GameWorks VR and Oculus Runtime 0.7, which means the GTX680 is certainly not "under specification", the same way the AMD hardware in Playstation4 is not under a minimum specification.

    There is no way you can tell me that a GTX680 is causing the issue by being a slower card, when it ran all my UE4 projects fine up until a certain point. You cannot pass the buck here, the issue is with a software update and it seems that no official staff at Epic are interested in finding out what part of that software update could have affected performance so dramatically.

    ---

    Is there any way of contacting Nick Donaldson or Nick Whiting?
    Last edited by mechanicalsnowman; 10-08-2015, 04:54 PM.

    Leave a comment:


  • replied
    Hey guys I'm just going to chime in, AO is not the problem here, it has terrible performance in 4.9 but disabling it is not a fix for a separate problem, you are just making up the frame time by cutting back elsewhere. I'm also running VR on an older card with an intent to package for 970s and 290s to scale with the increase in specs for the CV1 HMD, I am doing this because the newer generation of VR headsets require different level of processing power, I will often test my project on a computer with a 970 in but this does not give me an accurate representation of how the game will play on a headset that needs significantly more data pushed to it per second (DK2 VS CV1 - Resolution: 1920x1080 vs 2160x1200 Refresh Rate: 75hz vs 90hz)
    I am well aware of the 'recommended specs' oculus has given for VR rigs but they are entirely arbitrary specs not intended for developers to use during development other than final stage optimisation (for the studio's optimisation engineer to do with a representative piece of hardware) but instead for consumers to know that their machine will be able to run the majority of games as a comfortable experience. A stylised unlit game with a custom post process could run buttery smooth on a laptop with integrated graphics despite this having literally a tenth the processing power of an i5 4690 and a GTX970 but that's not we are discussing,
    There is a major difference in frame time that cannot be attributed to lower hardware specs or AO as I have noticed it in a project where there is none enabled in the postprocess and my frame time is worse across identical projects just because of the runtime. If this means you have to work more closely with Oculus to maintain the high standards of performance that had been set up until now I'd concentrate on this, I'd also suggest working towards maintaining frame time across projects otherwise the adoption of later versions of the engine (and the great features they provide) will be greatly reduced as a result of it's (admittedly necessary) restrictive nature on the subject of runtimes.

    In summary, there is serious a problem (most likely in the runtime or it's implementation in UE4 and although it is just conjecture I think it may be the latter) and this should be escalated properly with optimisation engineers and engine developers and not fixed by telling developers to make the scenes easier to render (reduce frame time by turning off AO).
    Last edited by XplosivduX; 10-08-2015, 03:30 PM.

    Leave a comment:


  • replied
    Originally posted by mechanicalsnowman View Post

    As for your other points, there is no hardware specification for VR at all, and especially not for developer kits.
    Did you read the official Oculus Blog post I linked? In there they clearly state that the recommended specs for development and users will be around the following for the rift.

    NVIDIA GTX 970 / AMD 290 equivalent or greater
    Intel i5-4590 equivalent or greater
    8GB+ RAM
    Compatible HDMI 1.3 video output
    2x USB 3.0 ports
    Windows 7 SP1 or newer

    While these are only recommended specs they are official specifications from Oculus stating which hardware you should be targeting and using for development. With that said your Nvidia 680 GPU is just not powerful enough for rendering things in VR without ensuring that what you are making is not overly complex and extremely simple. I just tested the Vehicle Game(Sorry I missed that part) with a Vive and a DK2 using an Nvidia 980 GPU and in each instance when disabling AO made them run at frame.

    Originally posted by mechanicalsnowman View Post
    There should be no regression on any architecture that would imply Oculus or Epic are dropping support for certain cards, because if either company is doing that, it would be a very poor decision for developers.
    I never stated that we (Epic) we're dropping support for certain video cards so I am not sure where you got this from. If this is something that I lead you to believe then I am sorry about that. What I was trying to express to you is that with your current GPU (Nvidia 680) you're going to find it hard to run things at frame right out of the box with UE4 as even Oculus has stated that you are going to need at least a Nvidia 970 / AMD 290 equivalent or greater to get the full proper VR experience. Finally have you tried the Showdown VR demo yet? If so does that run at frame for you? That would be the best test to see if your GPU is up to the task of VR as that runs at frame on all the devices I test with and is a fairly good example of how complex you can expect VR scenes to be. Give that a try and let me know what your performance is.

    Leave a comment:


  • replied
    Originally posted by Sam Deiter View Post
    Now I know that in the past you stated that you were running at frame but you did not state what project you were using for testing.
    Yes I did.

    I used Vehicle Game (completely unmodified) to test because it's something that has a fair balance of CPU and GPU going on, and anyone else can download it to replicate these results.
    I noticed the problem on two separate personal projects of varying complexity, and then used Epic's own vehicle game to test.

    As for your other points, there is no hardware specification for VR at all, and especially not for developer kits. There should be no regression on any architecture that would imply Oculus or Epic are dropping support for certain cards, because if either company is doing that, it would be a very poor decision for developers.

    Leave a comment:


  • replied
    Originally posted by mechanicalsnowman View Post
    This isn't the case; none of my projects use AO, I bake it in with lightmass.
    Well mechanicalsnowman after looking at your previous post it looks like your GPU is under specced for VR so that could also be contributing to some of your issues. Oculus recommends that for VR you use at least an NVIDIA GTX 970 or AMD 290. You posted previously that you were using a Nvidia 680 which again falls below the min spec recommended by Oculus. Now that is not to say that you can not run VR projects at frame on a 680. You can but you will have to make some major cut backs and design changes to make sure everything is as simple as possible and you have as few objects on screen as possible. Remember that currently in VR you need to render everything twice so you could simply be maxing out what your 680 can do.

    Now I know that in the past you stated that you were running at frame but you did not state what project you were using for testing. If you can package up a project that you feel has regressed badly for us to take a look at we can try to narrow down if it is in fact it is your GPU that is holding you back some or if there is something else going on. Just and FYI but I have tested disabling AO and each and every PC that I disable it for will run my test VR project at frame so I am fairly confident that AO is an FPS killer in 4.9.

    Here is a link to the Oculus blog where they talk about the recommended specs for the Rift in case you wanted some more information.

    https://www.oculus.com/en-us/blog/powering-the-rift/
    Last edited by Sam Deiter; 10-08-2015, 01:30 PM.

    Leave a comment:


  • replied
    Originally posted by Fredrum View Post
    Same here I had turned off all post processing I could find in project settings and post process volume. Of course it has helped the frame rate but that was also the case before the upgrade in versions.
    It is the difference between old and new versions that is the key point.
    Well you do not need to go that far. For me just disabling AO got me back up to frame on my DK2 and Vive. Again there was a regression with the AO that made it cost almost 2.5 MS per eye or a combined total of 5 MS just for AO.

    Leave a comment:


  • replied
    Originally posted by hcenteno View Post
    Would that also explain why my frame rate went up back to normal when I brought down the Engine Scalability setting for Post Processing?
    Without looking at what it changed I can not say for sure but this seems like it would be in the realm of possibility.

    Leave a comment:

Working...
X