Announcement

Collapse
No announcement yet.

UE4.9.1 does not recognise Rift with 0.6.0.1, and has game breaking performance with 0.7.0.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Just wanted to confirm that I've got the same issue. Went from a solid 75fps in 4.8 to horrible judder and 47 - 57fps in 4.9, which means it's unusable, so I'm going back to 4.8. Hope a fix can be found.

    Comment


      #32
      I currently still need 0.6.0.1 due to it's backwards compatibility with some older 0.4.4 projects.
      Since I was already on 4.9.1, I ended up getting the 4.9.0 tag code from GitHub (uses the 0.6.0.1 runtime) and compiled the engine from source. No problems compiling from source and works now with Showdown project (GTX 980 Ti with 355.84, 75fps with HMD SP 200). So fear not the compilation from source.

      Comment


        #33
        Originally posted by jvr View Post
        I currently still need 0.6.0.1 due to it's backwards compatibility with some older 0.4.4 projects.
        Since I was already on 4.9.1, I ended up getting the 4.9.0 tag code from GitHub (uses the 0.6.0.1 runtime) and compiled the engine from source. No problems compiling from source and works now with Showdown project (GTX 980 Ti with 355.84, 75fps with HMD SP 200). So fear not the compilation from source.
        Is that the 4.9.0-release one, or one of the previews?

        Comment


          #34
          Originally posted by kaitou View Post
          Is that the 4.9.0-release one, or one of the previews?
          tags/4.9.0-release (311e18f)

          Comment


            #35
            Appreciated! I didn't see mention of which version of OR was being used where, so many thanks.

            Comment


              #36
              We've also seen the large VR performance drop with 4.9.1. Our framerates when using the Rift went from a solid 75fps to frequently under 50fps with no other changes other than updating to 4.9.1.
              Descent: Underground |

              Comment


                #37
                Originally posted by Stormwind View Post
                We've also seen the large VR performance drop with 4.9.1. Our framerates when using the Rift went from a solid 75fps to frequently under 50fps with no other changes other than updating to 4.9.1.
                Please try the following and let me know if this helps or not. While your game is running open up the console and input the following command.

                HMD SP 130

                After pressing enter see if your FPS goes back up to the 75 FPS you were seeing before.

                Comment


                  #38
                  Adding to the people who are experiencing serious slowdown on the UE4.9.1 + Oc0.7.0 combo.
                  It would be great if this could get looked at please?

                  Cheers
                  Fred
                  Last edited by Fredrum; 10-04-2015, 03:46 PM.

                  Comment


                    #39
                    Hey everybody,

                    I did some testing and figured out that it is most likely the AO Post Process that is causing the lag you are experiencing. Turn off AO by setting the intensity to 0 and see if your lag stops. I have tried this with a Vive and DK2 and both times disabling this made my frame rate go back up to normal.

                    Comment


                      #40
                      Originally posted by Sam Deiter View Post
                      Hey everybody,

                      I did some testing and figured out that it is most likely the AO Post Process that is causing the lag you are experiencing. Turn off AO by setting the intensity to 0 and see if your lag stops. I have tried this with a Vive and DK2 and both times disabling this made my frame rate go back up to normal.
                      Would that also explain why my frame rate went up back to normal when I brought down the Engine Scalability setting for Post Processing?

                      Comment


                        #41
                        Originally posted by Sam Deiter View Post
                        Hey everybody,

                        I did some testing and figured out that it is most likely the AO Post Process that is causing the lag you are experiencing. Turn off AO by setting the intensity to 0 and see if your lag stops. I have tried this with a Vive and DK2 and both times disabling this made my frame rate go back up to normal.
                        This isn't the case; none of my projects use AO, I bake it in with lightmass.

                        Comment


                          #42
                          Same here I had turned off all post processing I could find in project settings and post process volume. Of course it has helped the frame rate but that was also the case before the upgrade in versions.
                          It is the difference between old and new versions that is the key point.

                          Comment


                            #43
                            Originally posted by Fredrum View Post
                            Same here I had turned off all post processing I could find in project settings and post process volume. Of course it has helped the frame rate but that was also the case before the upgrade in versions.
                            It is the difference between old and new versions that is the key point.
                            Exactly. Whether it was 4.9.0 > 4.9.1, or 0.6.0.1 > 0.7.0.0, or a combination of both, something broke in between these updates and I'm willing to bet that it isn't a problem that can be reduced to one or two post process settings.

                            I've cross posted the thread here to try to get Oculus' attention. I'd appreciate if developers post in that thread with any specific information you have that could help Oculus with diagnostics. Their Runtime iteration time is incredibly long, unlike Epic's UE4 iterations; if it is a Runtime issue and it's not fixed in the next update, we could be in for a very long wait.

                            Comment


                              #44
                              Originally posted by hcenteno View Post
                              Would that also explain why my frame rate went up back to normal when I brought down the Engine Scalability setting for Post Processing?
                              Without looking at what it changed I can not say for sure but this seems like it would be in the realm of possibility.

                              Comment


                                #45
                                Originally posted by Fredrum View Post
                                Same here I had turned off all post processing I could find in project settings and post process volume. Of course it has helped the frame rate but that was also the case before the upgrade in versions.
                                It is the difference between old and new versions that is the key point.
                                Well you do not need to go that far. For me just disabling AO got me back up to frame on my DK2 and Vive. Again there was a regression with the AO that made it cost almost 2.5 MS per eye or a combined total of 5 MS just for AO.

                                Comment

                                Working...
                                X