Announcement

Collapse
No announcement yet.

UE4.9 Leap Motion HMD Mode not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by getnamo View Post
    For 4.9 Leap Motion is recommending people to use the unofficial plugin. That plugin has hmd mode working out of the box. Just select a vr player controller and say EchoRiggedhands character and it will just work.

    All the instructions are available at the github repo and there is a Jenga video series to show how to make a simple game for VR with it.

    Hope that helps
    Thanks! I will try that out.
    Even though it will be nice to have it working with the official plugin :X

    Leave a comment:


  • replied
    For 4.9 Leap Motion is recommending people to use the unofficial plugin. That plugin has hmd mode working out of the box. Just select a vr player controller and say EchoRiggedhands character and it will just work.

    All the instructions are available at the github repo and there is a Jenga video series to show how to make a simple game for VR with it.

    Hope that helps

    Leave a comment:


  • replied
    Any update?

    Leave a comment:


  • replied
    Hmm, no news on that problem?

    Leave a comment:


  • replied
    Any news on the update? I mean the 3D Jam is starting soon and this hasn't been solved.

    Leave a comment:


  • replied
    Lead writer at Leap Motion here. Sorry about this issue, folks -- we experienced issues with the LeapCharacterExample, so we had to pull it from the 4.9 demo pack. We're hoping to have a really solid update land before the 3D Jam on September 28th. In the medium term, we've actually been looking for a full-time engineer who can help us bring the Unreal plugin to the caliber that the community expects and deserves (https://www.leapmotion.com/careers?jvi=o1QOZfwo,Job). Stay tuned and thanks for your patience.

    Leave a comment:


  • replied
    Originally posted by rrstuv View Post
    Ya, this is weird because it worked back in 4.8.2
    Not really, there was an extremely high jitter added to the data (see https://answers.unrealengine.com/que...in-broken.html). Looks like they replaced it with another bug.

    Leave a comment:


  • replied
    Can confirm, I'm having issues with the demos and 4.9 too, the hands are way offset and is certainly not working as expected.

    Leave a comment:


  • replied
    HMD mode doest not work correct
    charactor hand does not in the right place

    Leave a comment:


  • replied
    Ya, this is weird because it worked back in 4.8.2

    Leave a comment:


  • started a topic UE4.9 Leap Motion HMD Mode not working

    UE4.9 Leap Motion HMD Mode not working

    I'm trying out the Leap Motion 4.9 demo examples and find that when building and running the demos (using Play->VR Preview) the leap is not using HMD mode.

    I can tell the leap is using up-facing mode because it does display the hands if you move them in that orientation. Obviously that does me no good cause its attached to the headset ;P

    I dug into the blueprint and code for LM_DemoControllerActor and looked at it's inherited LeapMotionControllerComponent settings. The Hmd Mode was not checked so I checked that and recompiled and tried again. Still the Leap doesn't use HMD mode.

    I looked at the Leap Motion API and they state the
    Code:
    POLICY_OPTIMIZE_HMD
    should be set. Looking at the LeapMotionControllerComponent.cpp the HMD mode is set to false by default (
    Code:
    bHmdMode = false;
    ) but that variable is the one I'm setting in the blueprint details, I can see where it is exposed to blueprints in the header file:

    Code:
    /** 
     * Whether to transform the tracking data as appropriate for a Leap Motion device
     * attached to an HMD. 
     */
    UPROPERTY(EditAnywhere, BlueprintReadWrite, Category = LeapMotion)
    bool bHmdMode;
    I also tried calling the exposed Use Hmd Mode function in blueprints. No dice.

    Click image for larger version

Name:	leapdebug.png
Views:	1
Size:	77.7 KB
ID:	1161072
    Anyone have recommendations how to fix this?
Working...
X