Announcement

Collapse
No announcement yet.

Vive performance way lower then DK2?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Vive performance way lower then DK2?

    I'm having trouble getting a smooth experience using 4.9 prev 4 & Vive HMD, while the same experience runs smooth as a donkey's ******* on a DK2. I know the Vive has more pixels to push but I'm struggling to accept that it would make that much of a difference? Anyone else here has a similar problem?

    #2
    There are many causes of this. If you have any other window overlapping the compositor, it kills performance. If the resolution of your game window does not match the resolution of the Vive screens, it kills performance.

    Comment


      #3
      - Internal framebuffer of Vive is 3024x1680 (DK2: 2364x1464)
      - Frametime for Vive is 11.1 ms (DK2: 13.3)

      Don't know if Valve has something like ATW in the pipeline like Oculus (I really hope so).

      Comment


        #4
        I did some more testing and with an new empty project (starter content) , tweaking all the known tricks for performance (post processing volume, fxaa etc..) i still have the same judder. Even when lowering r.screenpercentage to something ridiculous like 50 i have the same judder.

        Looks more like a bug in the Vive <> Unreal integration, since I can run all the vive demos silky smooth (secret shop etc..)

        bpeck, what do you mean with "If the resolution of your game window does not match the resolution of the Vive screens," ?

        Comment


          #5
          I finally found the issue that was causing the bad judder. It was an <executeconsole command r.setres 2160x1200f> , once I removed that I had a silky smooth experience , no idea why it does that but hey, I'll take it

          Comment


            #6
            Could it be, that this just deactivates the super sampling (reduces the resolution from 3024x1680 to 2160x1200f)? If this is the case, why did 'hmd pd xx' have no effect as you told?

            Comment


              #7
              Hey Illusionweaver, we're having the same issue over here at our office as well. Until recently we've been using an Oculus Crescent Bay prototype with Unreal and it was super smooth in both 4.8 and 4.9. Some of my co-workers are on DK2s and, like you said, they run super smooth too.

              Two of us have switched over to the Vive with 4.9 and we are seeing the same exact judder. It's so unpredictable that its borderline impossible to iterate in. I've got everything disabled as well and still no luck. Unfortunately I can't find the "setres" command you found, maybe we have a different problem?

              Comment


                #8
                scratch that just read through the post properly.
                Last edited by Opamp77; 09-09-2015, 01:40 PM. Reason: talking rubbish

                Comment


                  #9
                  Hi Dbulla, unfortunately the setres turned out not to be the culprit, sometimes I have smooth fps , but mostly I have horrible judder , even with a new fresh empty 4.9 project. There is little to none documentation both from Valve or from Epic on how to get the Vive working smooth in your UE4 project so I'm basically just doing trial & error over & over to try and pinpoint the problem. So far I'm still having a hard time developing VR with UE4+Vive tbh, while DK2 is silky smooth & problem free

                  Comment


                    #10
                    We may have found a fix. It looks like bpeck may have been right about overlapping windows. Try adjusting your monitor layout in the display settings to something like this (Display 2 is the HTC Vive):

                    Click image for larger version

Name:	vive_display_settings.PNG
Views:	1
Size:	44.7 KB
ID:	1087292

                    Both me and my co-worker did this and now have super smooth framerate and no judder. If this fixes it for you as well we may have solved the issue!
                    Last edited by dbulla; 09-09-2015, 02:03 PM. Reason: clarification

                    Comment


                      #11
                      This totally fixed my judder problems as well! Awesome thank you 100x

                      Comment


                        #12
                        Originally posted by dbulla View Post
                        We may have found a fix. It looks like bpeck may have been right about overlapping windows. Try adjusting your monitor layout in the display settings to something like this (Display 2 is the HTC Vive):

                        [ATTACH=CONFIG]56468[/ATTACH]

                        Both me and my co-worker did this and now have super smooth framerate and no judder. If this fixes it for you as well we may have solved the issue!
                        WTF. Let's hope Valve supports VRDirect/LiquidVR in the next release. This extended mode **** needs to die ASPAP.

                        Comment


                          #13
                          Haha, that worked perfectly !

                          That's a bloody nice trick !

                          Guys from HTC told me to use Unity as a solution ... !

                          Thanks A LOT mate !
                          Last edited by Fitzrurisk; 02-02-2016, 06:57 AM.

                          Comment


                            #14
                            I remember reading about SteamVR 1.0 having moving to direct mode. I also remember seeing git 4.11/4.12 check-ins related to SteamVR 1.0. Likely the engine guys are already on top of it, but won't be able to release until the proper SDK comes out with the consumer release (much like Oculus 1.0 SDK is being held until consumer release)
                            VR R&D @Shopify

                            Comment


                              #15
                              I am currently running into this problem, I just received the consumer version of the VIVE and I am using UE4.11. The performance between the Oculus DK2 and the VIVE are way off. (At least 75 FPS on the DK2 and about 44 on the VIVE.) We also have an Nvidia 980Ti card. For what ever reason I can not see the VIVE in the windows area to change display resolution. I only see one monitor at all times, even when running my UE4 game in VR mode. If any was encountering a similar situation and found a solution I would be most grateful if you could share what it takes to fix the problem. Thanks in advance! NickZ.

                              EDIT: I was able to take the VIVE out of direct mode, then I could shift the display in the windows area to change screen resolution, but when I played int UE4 the frame rate was not better it was actually worse. (Frame rate showed that it was the same, but in the VIVE the frame stutter was horrible, way worse than the direct mode.)
                              Last edited by NickZucc; 05-19-2016, 09:02 AM. Reason: Found Direct Mode

                              Comment

                              Working...
                              X