Announcement

Collapse
No announcement yet.

performance isues with oculus and large actors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    performance isues with oculus and large actors

    When building the lighting i got an error message with several of my large "bleuprint" actors saying the following: "[Actor] : Large Actor casts a shadow and will cause an extreme performance hit unless bUseBooleanEnvironmentShadowing is set to true

    A large Actor has been set to cast shadows - this will cause extreme performance issues and should have bUseBooleanEnvironmentShadowing set to true."

    when i run the map normally i stil get 80-90 fps, but running in stereo with oculus dk2 framerate drops to 30-50, in some places 60-75.. but a very heavy jitter is present when moving your head, this is sometimes coupled with warping objects..

    Im asuming that the large actors playes a role here, Since im not firmilliar with coding, im hoping there is a way to change busebooleanenvironmentshadowing in the editor itself?... But im geusing no...

    I've been unable to find much info on this.. is this coding that needs to be done on the actor, or does it have something to do with the lightsource coding?

    And also does anyone know if its possible to add code to these already created blueprints or will i need to recreate them with code enabled from the start?

    My specs are as followed:
    Win 8.1
    Intell i7 x980 3.3ghz
    20gb ram
    Gtx 980 gpu
    1tb ssd

    #2
    Did you try unticking all shadow related options for the actor you placed on the map in it's details settings?
    Headgear - VR/AR solutions

    Comment


      #3
      I would indeed untick everything shadow related. How 'big' is the mesh? How many faces? I'm curious myself as I seem to be hitting some performance issues with high polygon meshes in the DK2.
      vr and new media installations
      www.samuelwalker.xyz

      Comment


        #4
        @foxhound101:

        If you're only getting 80-90 fps before going into stereo/DK2 mode, then I would be very surprised that you would consistently hit the required 75fps for the DK2 (which really means you need to hit higher so you don't go below this). It is usually safest to assume that going stereo will double the drawing of everything, and thus cut your frame rate roughly in half. This isn't often true in practice (your frame rate will likely be better than half), but if you go in with that attitude then you'll have some headroom when you need it.

        - Dave
        Latest Demo, Turtle VR: http://www.turtlevr.com
        Mobile VR Jam 2015 Entry: Circumpaint
        VR game, Here Come The Dead: http://www.herecomethedead.com/
        Main web site: http://www.gnometech.com/

        Comment


          #5
          thanks for the replies guys, im running some tests now, will try unticking all shadow related options and let you know what happens. I am getting an enormous performance increase the moment I delete the directional light, so im assuming it has something to do with the shadowing.

          @artoculus.. that's the thing, the mesh really isn't that complicated, and in my opinion not very big either.. I built a house out of several class blueprints, each consisting of a view walls and floors, quite low poly-count.

          @Gnometech.. thanks for the info, thing is I tested the oculus performance on another map[the kite demo showcase map]. without the oculus I get nearly constant 120fps.. in stereo, the fps falls to 75, but whenever I look at the trees it drops to a suspiciously stable 37.4fps. As soon as I delete the directional light I get 75fps constant with oculus. do you believe I would get a performance increase with the titan x instead of the gtx980?

          Comment


            #6
            Make sure that your Directional light is set to Static and not Stationary or Dynamic and then re-build your lighting. This should help give you some performance back.

            Comment


              #7
              If you guys have done some lighting test to see what works and what doesn't. Can you tell me if you have set the level to have a day night cycle, how is the frame rates. I've been told that if you have the lighting to Moveable, it helps with performance because your shadows aren't backed. is that true.

              Comment


                #8
                Originally posted by seandennis View Post
                If you guys have done some lighting test to see what works and what doesn't. Can you tell me if you have set the level to have a day night cycle, how is the frame rates. I've been told that if you have the lighting to Moveable, it helps with performance because your shadows aren't backed. is that true.
                I am not sure who told you that but I am afraid that they are mistaken. Baked shadow and light maps will always be cheaper than dynamic shadows.

                Comment


                  #9
                  Originally posted by Sam Deiter View Post
                  I am not sure who told you that but I am afraid that they are mistaken. Baked shadow and light maps will always be cheaper than dynamic shadows.
                  Thanks Sam, I was told that. I looked around and some say, for better performance for the day/night cycle is to do it with matinee.

                  Comment

                  Working...
                  X