Announcement

Collapse
No announcement yet.

[VR] Bad performance /w particle effects

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [VR] Bad performance /w particle effects

    Hi all,

    I have some performance issues while using VR with UE4 and particle effects.

    My demo is pretty simple, just some static meshes (Cubes) with a texture.
    Post processing is off, no dynamic lightning, mostly using emissive color. Cast Shadow is off on every mesh.
    Works pretty solid. In non VR i get >300 fps, in VR i get ~100 fps.

    If I add a particle system (from the example content) my fps in VR drop to ~50 (=> Judder - 1 particle system is enough to do so).

    I am using a R9 280x² - not the best card, but it should be able to handle a few particles.
    Tryed different drivers and different UE versions.
    At the moment I am not able to use paticle systems, because they seem to need lots of power in VR...

    Has somebody a similar experience?
    Needs UE4 just more power?
    Do your self created particle systems need less power? Any workaround?

    This is how the game looks in general.
    I can post some more screens later if needed.

    Click image for larger version

Name:	cwsezevvwz8di9rqn.jpg
Views:	1
Size:	282.1 KB
ID:	1145581

    Thanks and best regards
    Alex

    #2
    Hello nn23,

    I was unable to reproduce this on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

    Quick questions:
    1. What version of the engine are you using?
    2. Can you reproduce this issue in a clean project?
    3. If so, could you provide a detailed list of steps to reproduce this issue on our end?
    4. Could you provide screen shots of the partical effect that you are using?
    5. Could you provide screen shots of how your particle is set up?



    Could you please take the above answers and apply them to an AnswerHub post about this issue? After that could you then post a link to that question here so that I can assist you further?

    Comment


      #3
      Hi Rudy,

      thanks for your fast answer!
      I will do the steps you mentioned and try to reproduce/narrow down this issue.
      I'm pretty new to game developement, so it might be something on my side.
      I'll see what I find! Thanks!

      Comment

      Working...
      X