Announcement

Collapse
No announcement yet.

High FPS with judder, vsync low fps but smoother

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    High FPS with judder, vsync low fps but smoother

    Hey all,

    So I am working on a little Rift demo. Turning off "hmd vsync" gives me 85-100 fps in the Rift, but I kept noticing that it didn't feel quite right. I added "hmd lp on" which helped some, but it still didn't feel super smooth. Not as smooth as you would expect at least. I turned HMD Vsync back ON, and FPS is capped at 59-60 (every once in a while it would start up at 30 for some reason), and yet it feels smoother than the 85-100 did with hmd vsync turned off. Does anyone have any insight into what's going on? Ideally I would like to stay above 75 AND have it feel smooth.... Can't figure it out.

    Thanks!

    #2
    See I've got the opposite issue.

    The editor runs fine with no FPS cap (110 fps) but when I add the limiter of 60 to the ConsoleVariables config, I get stutter.

    This is especially frustrating because our team needs the framerate to be a solid 60 due to UE4's lack of proper substepping

    Comment


      #3
      Originally posted by camelotvfx View Post
      Hey all,

      So I am working on a little Rift demo. Turning off "hmd vsync" gives me 85-100 fps in the Rift, but I kept noticing that it didn't feel quite right. I added "hmd lp on" which helped some, but it still didn't feel super smooth. Not as smooth as you would expect at least. I turned HMD Vsync back ON, and FPS is capped at 59-60 (every once in a while it would start up at 30 for some reason), and yet it feels smoother than the 85-100 did with hmd vsync turned off. Does anyone have any insight into what's going on? Ideally I would like to stay above 75 AND have it feel smooth.... Can't figure it out.

      Thanks!
      Turning VSync off would limit the effectivness of timewarp (if you have it on, you can test it like this), therefore even at 100fps (no/limited timewarp) vs. 60fps (timewarp) you are adding about 6-8ms of rotation latency - the crucial one (translation latency indeed improves a bit, 6.67ms) and some judder. I presume you have your rift in Direct HMD mode? Because in direct mode you get your standard VSync stepping (60fps, 30fps, 20fps etc.), while in extended mode you get adaptive VSync (limit at max, tear at lower fps) so you don't get those big fps jumps. Also set minimum desired frame rate to 75 (Settings -> General Settings -> Rendering) and I also have smoothed frame rate checked and set to min: 75, max 95.
      Last edited by N8128; 03-06-2015, 04:20 AM.

      Comment


        #4
        If your using it in extended mode, set your main monitor in windows to the Rift. This should stop vsync from locking at 60 if it is a vsync issue.

        Comment


          #5
          Originally posted by Joltz View Post
          If your using it in extended mode, set your main monitor in windows to the Rift. This should stop vsync from locking at 60 if it is a vsync issue.
          I have been using it in extended. This is a good suggestion, I'll check that out ASAP.

          Comment


            #6
            That's the odd thing, I'm in extended mode. I have also set my minimum desired frame rate to 75, although I don't have smoothed frame rate checked.

            Comment


              #7
              Interesting and very frustrating. Let's just check from the bottom up.

              Do you have the lates Rift software/firmware?
              What Engine version are you using?
              What OS are you running on?
              What GPU do you have?
              Do you have the latest GPU drivers?

              Hopefully this can give us all a bit of an insight so we can help you.

              Comment


                #8
                Originally posted by N8128 View Post
                Interesting and very frustrating. Let's just check from the bottom up.

                Do you have the lates Rift software/firmware?
                What Engine version are you using?
                What OS are you running on?
                What GPU do you have?
                Do you have the latest GPU drivers?

                Hopefully this can give us all a bit of an insight so we can help you.
                I am running SDK 0.4.4, UE4 version 4.7.0, Windows 7, 750 Ti, and it's probably been a few months at least since I checked if there were new GPU drivers

                Comment

                Working...
                X