Announcement

Collapse
No announcement yet.

Stereo FPS 1/10 of Nonstereo FPS (Performance Issues)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Stereo FPS 1/10 of Nonstereo FPS (Performance Issues)

    Hello UE4 community!

    I currently have the following problem: I have a simple 3d scene which I am able to navigate through at ~450 fps with stereo deactivated. As soon as I activate stereo however, my FPS drops to 37,5 (or ~40 with vsync off). I might be wrong here, but that seems too much of a cost for the calculation and distortion of a second viewpoint.

    So my question is: Is there a hidden setting I am missing which drops my FPS that much? I can barely reach 75 fps with the console command "hmd sp 50", which ofc. looks horrible.

    Using UE 4.6.1 and SDK 0.4.4, Windows 7, Aero disabled and Direct to HMD.

    Regards
    Last edited by Greedape; 02-16-2015, 07:05 PM.

    #2
    This is a known issue, If the FPS higher than 75 it gets stuck at 37. https://forums.unrealengine.com/show...-Is-there-hope

    4.7 will include 0.4.4, so that may fix things.
    Last edited by Alexotronic; 02-17-2015, 01:03 AM.

    Comment


      #3
      Originally posted by Alexotronic View Post
      This is a known issue, If the FPS higher than 75 it gets stuck at 37. https://forums.unrealengine.com/show...-Is-there-hope

      4.7 will include 0.4.4, so that may fix things.
      Shouldnt this be "if FPS is lower than 75, it gets stuck at 37.5"? Also, I tried with Vsync off and like i wrote, the Framerate is at about 40. What I want to know is how any of this can happen. 1/10th of the regular framerate?

      Comment


        #4
        Hello! I posted how my team was able to achieve 75 fps consistently in the thread that was linked here so I'm just copy and pasting what was in that thread.

        This is how we were able to get to 75fps in our level. First off kill everything in the post process settings in project settings (you can keep AO for static objects and anti aliasing)
        Delete your reflection sphere.
        Open couch knights and copy there post process volume over and replace yours with it.
        Turn every light you have in your scene to static.
        make sure to build lighting.
        Launch and make sure you are in direct to rift mode (extended caps at 60)

        Also we found that keeping it under 500 draw calls (250 in each eye) helps tremendously

        Let me know if this helps it might just be a solution for us.

        Comment


          #5
          Also, if you happen to be using an NVidia graphics card, in the GeForce driver, try to set the power management to "performance", it's helped me get better performance in Direct Mode with my 680:

          https://forums.unrealengine.com/show...l=1#post218152

          Comment

          Working...
          X