Announcement

Collapse
No announcement yet.

Gear VR support?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #61
    I am getting a bunch of Anti Aliasing and other bad visual artifacts also :/

    Comment


      #62
      @JW and haggler2: thanks for pointing it out, the engine's compiling now.

      @haggler2: I dunno why I got those errors too, I think it was probably because I checked out the release branch and tried to merge the master into it.

      Comment


        #63
        I built the C++ FPS template level and got it running on the Gear VR and I'm wondering about 2 things:

        1) it is choppy like everyone mentioned though I don't have any artifacts, just a bit of flicker on the gun and slight choppiness, not as smooth as the Oculus demos for sure. Can someone from Epic or someone that's gotten it working recommend some settings to use. Should we use the same settings as the Couch Knights demo? That will be my experiment for tomorrow to see if that smooths things out.

        2) More importantly, the FOV seems smaller and more square than any of the Oculus demos, is that something we need to tune or will that be fixed soon? Is that due to the FOV being actually lower or a need to turn on vignette so that the borders of the rendering aren't so apparent? I felt completely immersed in the Oculus demos and right after that tried out the FPS level and immediately saw the rectangular edges of the rendering which was quite jarring.

        Very exciting step though running our own Unreal-based VR apps completely untethered.

        Comment


          #64
          Also, my second attempt which involved copying some of the settings from Couch Knights has backfired and now I get both images squished on the left half of the screen and it is choppy. The right half of the screen/right eye is black. Hopefully these will improve by the time 4.7 is finished. JJ, please check in your performance progress to the 4.7 branch rather than saving it for the final release so we can test and give feedback in the interim

          Comment


            #65
            Has anyone tried with the 4.7 fork from Oculus? If so, any better results?
            Last edited by NobleSpoon; 02-08-2015, 02:04 PM.
            Klepto - Burglary Simulator

            Comment


              #66
              Some other observations purely off of the FPS template:
              1) turning off the fog volume disable rendering in the left eye
              2) shadows are messed up
              3) without disabling occlusion completely objects pop in and out of view like crazy, with occlusion disabled there are no shadows on the left eye but everything is there
              4) I have some odd ghosting where it looks like a fixed view is always rendering as a ghost on the main image, maybe it is fixed from the perspective of the light for shadows, not sure

              Comment


                #67
                Ok, I'm having a little bit of luck with my BP based project. Since I'm not using a HUD element, I added a C++ HUD class to the project and set it as the default HUD. This seems to do the trick for getting the plugin to run. Now I just need to get it working for BOTH eyes. Originally, it was split screen in the left eye, nothing in the right. That seems to be because I forgot to set the project to scaleable 3D. After correcting that, the left eye is normal but still nothing in the right eye.

                I'm currently using the Oculus-VR fork of 4.7 for my testing. I'm going to make another copy of my project and try with the 4.7 from Epic to see if this resolves my right eye issue. If not, Pirate Simulator 2015 will be my next title
                Klepto - Burglary Simulator

                Comment


                  #68
                  Originally posted by NobleSpoon View Post
                  Ok, I'm having a little bit of luck with my BP based project. Since I'm not using a HUD element, I added a C++ HUD class to the project and set it as the default HUD. This seems to do the trick for getting the plugin to run. Now I just need to get it working for BOTH eyes. Originally, it was split screen in the left eye, nothing in the right. That seems to be because I forgot to set the project to scaleable 3D. After correcting that, the left eye is normal but still nothing in the right eye.

                  I'm currently using the Oculus-VR fork of 4.7 for my testing. I'm going to make another copy of my project and try with the 4.7 from Epic to see if this resolves my right eye issue. If not, Pirate Simulator 2015 will be my next title
                  Do you have a fog volume? For some reason the FPS template won't show anything in one of the eyes without it. Weird.

                  Comment


                    #69
                    No fog volume. I did have it working on both eyes for one test build. It seems to have broken again when I added HMD SP 95 on begin play. I will try adding a fog volume on my next build. Thanks.

                    EDIT: The issue seems to be caused by setting a value less than 100 for HMD SP XXX command. Set to 100, no issues. Set to 95 and only one eye again.
                    Last edited by NobleSpoon; 02-08-2015, 07:04 PM.
                    Klepto - Burglary Simulator

                    Comment


                      #70
                      Originally posted by NobleSpoon View Post
                      No fog volume. I did have it working on both eyes for one test build. It seems to have broken again when I added HMD SP 95 on begin play. I will try adding a fog volume on my next build. Thanks.

                      EDIT: The issue seems to be caused by setting a value less than 100 for HMD SP XXX command. Set to 100, no issues. Set to 95 and only one eye again.
                      Are you getting any weird ghosting over one eye which looks like it could be the shadow pass? I get it in the left eye. That and all the shadows are broken and object culling seems completely off. This isn't specific to Gear VR but just VR in general so this seems like a general regression from 4.6 as the FPS template is completely broken regardless of DK2 or Gear VR.

                      Also, how's your FPS?

                      Edit: Maybe the FPS is better on the Oculus build compared to the 4.7 branch from Epic which is what I'm using?

                      Comment


                        #71
                        I haven't seen the ghosting issue. Originally, I was getting 30FPS. I have stripped down everything in my level to bare minimum and it is locked in at 60FPS. I'm slowing adding things back to find the performance hit.

                        I'm not sure about the one from Epic but the Oculus fork added Set/Get Screen Percentage which seems to be a replacement for the broken HMD SP XXX. However, I've tried setting various values but it doesn't seem to be taking them.
                        Klepto - Burglary Simulator

                        Comment


                          #72
                          Odd, I couldn't get the Oculus branch to work with Gear VR at all. I built the 4.7-np branch, made sure I had all the Android dependencies installed as in the Epic 4.7 branch. I cleaned all the directories, switched from the 4.6 to 4.7-np branch and ran Setup.bat followed by the GenerateProjectFiles.bat. Built Development and Development_Editor as I did for Epic and started up a new template same as my other Android ones. There doesn't seem to be a Gear VR plugin to enable, there is no mention of Gear VR in the Android settings for packaging and when I ran the simple FPS C++ project and tried to fullscreen for the Oculus plugin it didn't work. Just would hang and not render till I alt+entered back. Also, opening one of the projects I created with the Epic branch complains about the lack of a Gear VR plugin. I guess I'll have to wait for a response and changes from Epic tomorrow hopefully to see how soon we can get simple Gear VR projects running. Testing out the Oculus-built demos blew me away completely and they aren't using Unreal, I can only imagine how nice things will be once we have this engine working full-speed.

                          Comment


                            #73
                            Is OpenLevel working for anyone? It is just reloading my current level every time I try to use it.
                            Klepto - Burglary Simulator

                            Comment


                              #74
                              Ok guys, I'm back. So I downloaded the 4.7 branch and compiled the editor, it worked fine. Now, I've put my project in it, but it refuses to package the build, even for windows 64 bit, and gives the following error:

                              LogNavigation:Error: No navigation data types found while setting up required navigation types!

                              Any ideas?

                              Comment


                                #75
                                Originally posted by NobleSpoon View Post
                                Is OpenLevel working for anyone? It is just reloading my current level every time I try to use it.
                                I tried it two days ago for one of my projects and it worked fine.

                                Originally posted by mdhananjay View Post
                                Ok guys, I'm back. So I downloaded the 4.7 branch and compiled the editor, it worked fine. Now, I've put my project in it, but it refuses to package the build, even for windows 64 bit, and gives the following error:

                                LogNavigation:Error: No navigation data types found while setting up required navigation types!

                                Any ideas?
                                This sounds more like a change in the 4.7 codebase than an issue with Gear VR, maybe AnswerHub can help. Have you tried one of the plain sample projects to get up and running that way? I have huge issues with the sample projects both on the Rift and on Gear VR, not very promising at the moment.

                                Comment

                                Working...
                                X