Announcement

Collapse
No announcement yet.

Gear VR support?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    has anyone had any luck launching Samsung note 4 successfully using preview 3 yet?

    Comment


    • #32
      Originally posted by haggler2 View Post
      I consider myself an early VR adopter. I have Google Cardboard, DK1, DK2, and now GearVR. As you probably know GearVR is on a completely different level than Cardboard. Google Cardboard is actually pretty terrible as it stands right now. The latency is aweful, and I personally could care less if Epic added support for it really.

      It's okay for getting a really rough idea of what VR is like if you are on a tight budget. But still pretty terrible nonetheless. Until google makes some big changes on the software side (and I don't think that would even be enough, probably need additional IMUs I imagine) I won't be supporting it personally, do not care if there are more potential sales for myself (because more users would have access to it). I won't support something I don't think is up to par. The only thing I care about is VR actually succeeding this time around, even more than myself making a few bucks riding the VR hype train. I will not play any part in potentially poisoning the VR well as I believe products like cardboard do. Hope this doesn't come off as too harsh, I just dislike cardboard.
      Yeah, I agree, Cardboard experience cannot compete with GearVR now, but I think hardware developers will develop DIY Cardboard with dedicated IMU in it to enhance the overall experience.
      As content provider, I simply see potential in it. But who knows, it may turn out to be good or bad in this coming year. I just hope when it turns out good, my content can be ported to it without too much trouble.

      Comment


      • #33
        It doesn't look like theres been much success in getting a build on the gear so that makes me feel a little better I did note that some of you are putting the "VR_only" line inside the androidmanifest.xml file of the project folder, I've been talking to to a dev from unreal and he told me to put that line inside the androidmanifest file of the engine/build/android/java.

        Does anybody know if we are supposed to save the file on the sd card? When I launch the project it builds and creates the executable on my phone and when I touch it it tells me to connect gear to my device when I do the screen goes black and just takes me to oculus home. I was thinking maybe i just need to put the .exe into the folder with all the other games similiarly to how you put video on the gear but I couldn't find where the game executables are stored.

        Comment


        • #34
          where exactly do you put the VR_only inside the andriodmanifest.xml? what is the syntax?

          Comment


          • #35
            Hi All, I'm Trying to get the GearVR plugin to work in Unreal and build out to the phone.

            I've tried to work out from all of the above posts what i'm "step" i'm missing to get past the ~"GearVR" module is missing~ message that pops up on the phone. I'm just installing Visual Studio to see if you have to run projects in C++ mode and not as a blueprint, but other than that i'm stumped and its probably really obvious.

            Unreal 4.7.0 preview 4
            New project empty blue print
            GearVR plugin enabled and restarted

            Project-Settings-Packaging: "Package .pak in APK" selected
            Platforms-Android: Platform files are Writable in green

            Edited AndroidManifest.xml in Project-folder/Build/Android
            Added line <meta-data android:name="com.samsung.android.vr.application.mode" android:value="vr_only"/> after <application>
            Have also tried just before </application> tag.

            Also added Camera Permission, out of desperation.
            <uses-permission android:name="android.permission.CAMERA" />

            Samsung SM-G900X
            Android 4.4.2

            Tried both File>Package Project>Android>Android(All) and File>Package Project>Android>Android(DXT)

            I have the oculus SDk downloaded, but not sure if i have to do anything else with it.

            Any advice appreciated.

            Comment


            • #36
              Edit/Update: Tried the following, it didn't work for me.

              Here are MarcelBlanck's instructions:

              ...It might be possible on preview, but I did it on the master branch. It should be possibe on promoted also, master was only a few commits ahead.

              1. Make sure all Verions SDK, ANT, NDK are standard for UE4 and on PATH. So just let the the UnrealEngine/Engine/Extras/Android/tadp-2.0r8-windows.exe do it's job
              2. Checkout the master or promoted branch
              3. Open Visualstudio and build the whole Project with x64 | Development Editor
              4. After that build one mor time but only UE4 by rightclicking on it and with target Android | Development
              5. In the explorer go to UnrealEngine\Engine\Source\ThirdParty\Oculus\LibOVRMobile\LibOVRMobile_041
              6. Execute the InstallVRLib.bat
              7. Open your Project with the build Engine Editor and make sure it has the Project Settings > Target Hardware to mobile and scalable, under Input select Default Touch Interface and clear it (we do not want that sticks)
              8. Enable the GearVR plugin!
              9. In UE4 Editor, I have set the Project Settings> Andoid SDK paths correctly to the one you build the engine with
              10. Go to Project Settings > Android > APK Packaging and set Minimum SDK version to 19
              11. Go to Project Settings > Android > Advanced APK Packaging and add <meta-data android:name="com.samsung.android.vr.application.mode" android:value="vr_only" /> (To bad they automated the Manifest production)
              12. In the same category, a few lines below, add android.permission.CAMERA to the Extra Permissions
              13. Check the rest of the settings is default, ES2 and arm 7 build selected
              14. IMPORTANT - got to your Projects folder MyProject/Build/Android and create a folder named "assets" - put your downloaded generated Oculus signature file in that folder
              15. Go to File > PAckage Project > Android > Android ETC2

              DONE!

              I still had a crash with the FPS Template, the android debug log said the Crosshair Texture was null... wtf. I deleted it in the project and I was able to run it, and look around with my GearVR! So make sure you check your adb logcat output and find the exact reason for a the problem if you get a black screen - Mostly it will be near words like Exception ot WINDEATH

              If you want full Samsung controller support apply the patch in the original post here. I will now start to check what kind of events the build-in touchpad and Backkey throw. I also need to know how to access the GearVR Main Menu and how to go to Oculus Home. So still some work to do. Then the development fun can begin.

              [/I]
              Last edited by haggler2; 01-31-2015, 08:46 AM.

              Comment


              • #37
                New update in the Master branch to the 0.4.2 Mobile SDK which probably means it has some other fixes as well. Anyone care to give it another go?

                Comment


                • #38
                  Alright. For anyone who wants to grab the latest from the GitHub 4.7 branch, these instructions should get you started.

                  Prerequisites:
                  - Have a Note 4 and GearVR kit, and already be set up with the ability to build and deploy Android UE4 projects to your device
                  - Grab 4.7 from GitHub and run the Setup.bat in order to get the latest binaries. Please make sure to re-run Setup.bat if you have already run it, because there are new libraries for GearVR support
                  - Get an osig file for your device from https://developer.oculus.com/tools/osig/
                  - Create an 'assets' directory within Engine/Build/Android/Java, and place your osig file in this assets directory. Your project *will not run* on device without this osig present in this directory at packaging time

                  Build and Run the editor:
                  - Run GenerateProjectFiles.bat to update your solution
                  - Open ue4.sln in visual studio, and build and run the UE4 project in 'Development Editor - Win64' configuration

                  Create your project:
                  - Select the 'New Project' tab
                  - Select the 'C++' tab (currently GearVR support requires a C++ project since plugins are not built into the default executables)
                  - Select the 'First Person' template
                  - Change the options to 'Mobile / Tablet', 'Scalable 2D / 3D', 'No Starter Content'
                  - Name your project something like 'MyGearVR'
                  - When visual studio opens up again, compile and run the MyGearVR project

                  Configure and package your project for GearVR:
                  - Go to the 'Windows/Plugins' menu item, and go to the Head Mounted Displays page - disable Oculus (optional) and enable GearVR, click 'Restart Now'
                  - Select the 'Edit/Project Settings...' menu item
                  - In the Android section, scroll to the top and click the 'Configure Now' button for Android support
                  Set the Minimum SDK version to 19 or higher
                  Select the 'Configure the AndroidManifest for deployment to GearVR' checkbox
                  - In the Packaging section, optionally click the advanced down arrow in Project and disable 'Full Rebuild' in order to speed iteration times
                  - Select the 'File/Package Project/Android/Android (ETC2)' menu item and package your project to a directory of your choosing

                  Install and Run:
                  - Connect your device and have it able to accept adb sessions. Please see the normal UE4 Android documentation for details if you're not familiar with this process
                  - Run the installation script from within the directory you packaged to
                  - On device, find your application icon, click it, and then attach the GearVR headset to the phone

                  Comment


                  • #39
                    - Select the 'C++' tab (currently GearVR support requires a C++ project since plugins are not built into the default executables)
                    I think this may have been where I was messing up this entire time, and Java folder for signature file.

                    Any ideas on when blueprint-based projects will get support? I am getting pretty ok with the blueprints but not very good with the C++ based projects yet. Thank you for the instructions btw.
                    Last edited by haggler2; 01-31-2015, 09:06 AM.

                    Comment


                    • #40
                      C++ Mmmmm... I am all blueprint but I saw this :

                      "How to Convert a BP/Content Project to a C++ Project in 8 Steps"

                      I have to try it as my GearVR project is done, so I'll report back here.
                      Welcome to my universe,
                      www.SynthesisUniverse.com
                      Get the NEW Nov 10th 2014 demo !
                      SU -Maze- on Oculus Share

                      Comment


                      • #41
                        Yep i'm pretty sure Hoesing didn't mean C++ only, you just need to add a new empty code class to any blueprint project and it automatically becomes a C++ project. Blueprints will still work as usual.

                        Comment


                        • #42
                          Yeah, the key thing is that blueprint only Android projects will use a prebuilt executable that doesn't contain the GearVR plugin. There just needs to be some C++ present to kickstart a compile and link with the plugin included. This may not be strictly necessary, but it works for now.

                          Comment


                          • #43
                            Phew, that is good news/info

                            I did not realize when I commented that you could mix the two without issues. Will give this a go tonight

                            Comment


                            • #44
                              AWESOME it is WORKING!!!

                              Comment


                              • #45
                                Excellent

                                Comment

                                Working...
                                X