Announcement

Collapse
No announcement yet.

[Question] No audio through rift

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Hi, I'd like to second this bug.
    We recently moved from 4.24 to 4.25.
    With 4.24, it worked fine. In editor, you could preview sound assets and they'd play through the default Windows device, but when using the VR Preview, the game audio would automatically play through the headset.
    With 4.25, you have to manually tell Windows that VR Preview should play audio through the Rift. It's awful, because to preview sounds in the editor, you need to switch it back.

    Leave a comment:


  • replied
    Right, I understand that. But most oculus specific programs will automatically switch the default playback device to the rift when launched. I guess that's what I'm trying to replicate.

    Leave a comment:


  • replied
    Sounds like its working as intended? By default, your PC shouldnt be piping audio to the HMD unless Windows has the HMD set as the desired audio output device. If you leave Windows to 'default' audio device, it might not automatically trigger the change to HMD once it's worn. You could also check in the Oculus app, click 'Devices' and then click your HMD to make the right-hand window open, then find options labelled 'Hear VR audio from computer' and 'Hear computer audio in VR' and toggle/untoggle these as desired.

    Leave a comment:


  • started a topic [Question] No audio through rift

    [Question] No audio through rift

    I am working on a VR project for the oculus rift, and while everything else works fine with the headset I cannot get audio to play through the rift by default. It works fine if I set the windows audio device to the rift speakers, but otherwise sound just plays through the default speakers.

    This is true whether the game is fully built or just run in editor. Am i just missing some obvious editor setting?

    Thanks for any help.
Working...
X