Announcement

Collapse
No announcement yet.

Oculus Quest 4.25.3 Issues.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Oculus Quest 4.25.3 Issues.

    So I started a new project with the latest version of UE4 after all the android setup I was able to successfully build and push to my Oculus quest. The problem is that when the apk is run all I get is a black screen. I have all of the map options setup correctly and even changed them to a almost empty level to make sure it wasn't just trying to load a lot of data. I have tried a million fixes but all have left me with the same black screen. Ordinarily if you get a black screen it means your default map isn't set or your map wasn't packaged with your game. The maps are set and the obb file is almost 28 mb's so there is data there. I'm banging my head against the wall here trying to figure out why. I have noticed that when I try to test the project with the mobile preview it freezes up and under the processes it is compiling shaders. Any help would be very appreciated, I have successfully gotten this working before but for whatever reason something in 4.25 as made things more difficult.
    Modular House Interior Pack

    Medieval Dinnerware Pack

    #2
    Can you post which versions of the ADK, NDK, JDK, and gradle you are using? I keep getting a Gradle error while trying to build.

    Comment


      #3
      I had the same issue. https://answers.unrealengine.com/que...4245/view.html

      I managed to fix it by making a build batch file which deletes the .apk file in the binaries folder before building. Not sure why that works but it seems to work for me.

      example:

      Code:
      
      set ProjectDir=C:\Pixnami\Projects\%1\Unreal\%1\%1.uproject
      set BuildDir=C:\Users\Joost\Desktop\Builds\Development
      del %BuildDir%\Android_ASTC\*%1*.obb
      del %BuildDir%\Android_ASTC\*%1*.apk
      del C:\Pixnami\Projects\%1\Unreal\%1\Binaries\Android\*.apk
      cd /D "Y:\UnrealEngine\Engine\Build\BatchFiles\"
      call RunUAT.bat BuildCookRun -nocompileeditor  -project=%ProjectDir% ^
      -noP4 -platform=Android -cookflavor=ASTC -clientconfig=%2 -serverconfig=%2 -build^
      -cook -package -build -stage -pak -cook -prereqs -utf8output -compile  -crashreporter -archive -archivedirectory=%BuildDir%

      Comment


        #4
        I had noticed that a couple times deleting the past build and uninstalling it from the quest seemed to fix the issue but it didn't always work. I'll try your fix though.
        Modular House Interior Pack

        Medieval Dinnerware Pack

        Comment


          #5
          Joost, could you explain a bit more in depth on how you fixed the issue?
          Where do I put the batch file and what do the lines mean, so I can update them for my situation?
          Thanks in advance!

          Comment


            #6
            Originally posted by Dikkop View Post
            Joost, could you explain a bit more in depth on how you fixed the issue?
            Where do I put the batch file and what do the lines mean, so I can update them for my situation?
            Thanks in advance!
            Sure! Although I've noticed sometimes that trick doesn't work and the only way I've found to solve it is to delete my intermediate and binaries folders and do a full rebuild.
            You can put the batch file anywhere you want. Just double click to run it. But you need to edit the paths to match the locations on your own PC. Also delete the comments I added before running it!



            Code:
            set ProjectDir=C:\location\of\yourProject\yourProject.uproject // set project directory
            set BuildDir=C:\Users\Joost\Desktop\Builds\Development // set directory where you want to store your builds
            del %BuildDir%\Android_ASTC\*.obb // delete old obb, probably not necessary
            del %BuildDir%\Android_ASTC\*.apk     // delete old apk, probably not necessary
            del C:\location\of\yourProject\Binaries\Android\*.apk // delete old apk in your project binaries folder
            cd /D "Y:\UnrealEngine\Engine\Build\BatchFiles\" // go to location of your unreal engine install
            call RunUAT.bat BuildCookRun -nocompileeditor -project=%ProjectDir%  -noP4 -platform=Android -cookflavor=ASTC -clientconfig=development -serverconfig=development -build^
            -cook -package -build -stage -pak -cook -prereqs -utf8output -compile -crashreporter -archive -archivedirectory=%BuildDir%

            Comment


              #7
              Originally posted by Joost View Post
              I had the same issue. https://answers.unrealengine.com/que...4245/view.html

              I managed to fix it by making a build batch file which deletes the .apk file in the binaries folder before building. Not sure why that works but it seems to work for me.

              example:

              Code:
              
              set ProjectDir=C:\Pixnami\Projects\%1\Unreal\%1\%1.uproject
              set BuildDir=C:\Users\Joost\Desktop\Builds\Development
              del %BuildDir%\Android_ASTC\*%1*.obb
              del %BuildDir%\Android_ASTC\*%1*.apk
              del C:\Pixnami\Projects\%1\Unreal\%1\Binaries\Android\*.apk
              cd /D "Y:\UnrealEngine\Engine\Build\BatchFiles\"
              call RunUAT.bat BuildCookRun -nocompileeditor -project=%ProjectDir% ^
              -noP4 -platform=Android -cookflavor=ASTC -clientconfig=%2 -serverconfig=%2 -build^
              -cook -package -build -stage -pak -cook -prereqs -utf8output -compile -crashreporter -archive -archivedirectory=%BuildDir%
              Hi how can i contact to u to know the details how to write the code correctly? because i m new to unreal engine and i m not sure the location of file that i wrote is correct anot...thank you! (ps: i ald pm to ur inbox)

              Comment

              Working...
              X