Announcement

Collapse
No announcement yet.

VR - Widgets Buttons, problems with the Thumbstick and with the Focus ?? Help please.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    VR - Widgets Buttons, problems with the Thumbstick and with the Focus ?? Help please.

    Good morning, obviously I'm a novice, so sorry for the stupid question.
    But it's been 2 days since I haven't been able to find a solution, I've looked at every guide on youtube, I've read many posts, but nothing.

    I must say that my experience with this graphics engine is making this period of quarantine very pleasant (not that before the quarantine, I left home a lot :/),
    I have fun and I am excited to use this engine.
    But in some moments like this, I would like to cry.

    Then..

    I am using an Index Valve (helmet and controller), to the player I hooked a component to which a widget is mounted.
    This widget will then be populated by additional child widgets.

    When I interact with the NPC I display several dialogues and questions which are accompanied by dynamic answers (buttons) from another widget.

    WIDGETS:

    QUESTION CONTAINER:
    https://i.gyazo.com/00c4e90346c6533d...7848462d2e.png

    Click image for larger version

Name:	00c4e90346c6533dacdfe57848462d2e.png
Views:	139
Size:	137.1 KB
ID:	1775588
    BUTTONS QUESTIONS:
    https://i.gyazo.com/fc6fbbcba8084315...4c540a82d3.png
    Click image for larger version

Name:	fc6fbbcba808431566f3464c540a82d3.png
Views:	66
Size:	134.4 KB
ID:	1775589



    BP SCRIPT (MAKE QUESTION BUTTON):
    https://i.gyazo.com/37b338ff0a2b1b49...22c30d5116.png
    Click image for larger version

Name:	37b338ff0a2b1b4920706a22c30d5116.png
Views:	75
Size:	535.9 KB
ID:	1775590




    I correctly see the NPC question and its answers (BUTTONS)

    The problem is the selection of the buttons, I tried focus everywhere to test .. but nothing, the best result was:

    I see the question, I see the answers (BUTTONS) and, with the keyboard, if I press "enter" it does nothing ..
    But if I press "down" I miss the first button but I focus the second,
    from here I can press enter and proceed or go up to the button that I missed and continue them by pressing enter.

    I noticed that, if at the first display of the buttons, I press TAB, I focus correctly on the first button.

    So, besides the fact that I don't understand why the thumbstick doesn't select the buttons, I can't get the buttons to work properly, even when I use the keyboard.

    I really hope someone can help me, I usually avoid asking without research (which I did), but this situation after 2 days has become frustrating

    Thanks

    #2
    Ok ... now the focus works .. apparently I wasn't focusing on the button ... ok I'm stupid but ..
    Now according to you .. what is the best accommodation between these two?

    1) "Old"
    https://i.gyazo.com/e66bbdca29294e14...d94d1d4544.png

    Click image for larger version  Name:	e66bbdca29294e14f3dc39d94d1d4544.png Views:	0 Size:	407.9 KB ID:	1775644


    2) new

    Click image for larger version

Name:	7ad55965d0580bb20fa8fa3ab1d402a4.png
Views:	67
Size:	229.5 KB
ID:	1775646
    https://i.gyazo.com/643f4ed7ab61696b...9bfbe96dee.png

    Click image for larger version  Name:	643f4ed7ab61696b91f6759bfbe96dee.png Views:	0 Size:	183.1 KB ID:	1775645


    Besides, the VR thumbstick still doesn't work in the widget .. instead the keyboard works perfectly
    Last edited by GTOokami; 06-13-2020, 07:25 PM.

    Comment


      #3
      I changed everything again.
      But I can't find a way to control HUD with the Index Controller.

      I provisionally created a BP Interface to manage Thumbsticks.
      But to manage the button to simulate clicking on the answer buttons, it would cost me many functions in the BP Interface. And I don't think it's the right method.

      Can someone help me?


      Controller Pawn:
      https://i.gyazo.com/a6e295644b243bed...6dd67aac67.png

      Widget:
      https://i.gyazo.com/e6811209dff9a028...74f138275e.png

      Comment

      Working...
      X