Announcement

Collapse
No announcement yet.

[AR] Setting the passthrough camera brightness

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [AR] Setting the passthrough camera brightness

    The camera brightness/contrast/exposure is set quite low compared to how the camera's image normally looks in the phone's camera app. Is there a way to control these settings through the Unreal Engine AR framework?

    Thanks!
    - Skerzan

    #2
    Bug in Unreal Engine. See here: https://issues.unrealengine.com/issue/UE-90099
    The bug is also to be seen in screenshots in the Unreal Engine documentation, ridiculous...
    They will not fix it, because they don't care about Mobile AR anymore.

    Enable MobileHDR in the project settings. Only way to make it work.

    Comment


      #3
      Thank you for your reply, however MobileHDR is already selected so I'm not sure what to do here to fix the issue.

      Comment


        #4
        MobileHDR enabled fixes this issue only on iOS.

        Several users still report this issue using ARCore on android.

        There are several other posts with this same issue in the forums and discord,
        however no one bothered to make a bug report: https://www.unrealengine.com/en-US/support/report-a-bug
        (I have no android device at hand and I don't feel comfortable reporting a bug i never experienced myself.)

        Comment


          #5
          Thanks for mentioning that, yes I'm using ARCore on Android. I have reported the bug and will let you know what the result of that is.

          Comment


            #6
            Skerzan Great, thank you for your effort!

            Comment

            Working...
            X