Announcement

Collapse
No announcement yet.

Android AR not spawning fog emitters

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Android AR not spawning fog emitters

    Hello, I am on UE 4.24 working on an Android AR app. I need to have a sort of fog wall appear in one scene. I have a basic volumetric fog set to a particle emitter to spawn at the phone's location on the app's startup. It works on the simulation window but when launching on my phone I am seeing no fog. I have both mobile HDR enabled and "Disable Vertex Fogging in mobile shaders" unchecked. Is there something special with mobile particle systems I'm not aware of?

    #2
    Tried having it spawn somewhere else? the phone location maybe the issue? Or spawn something else at that location to see if you can see it (like a text 3dwidget) just to make sure it's really a specific problem with that emitter. In general particle emitters work fine in mobile AR
    Headgear - VR/AR solutions

    Comment


      #3
      Yeah I threw in a text actor at 0,0,-1 for just a lil offset from the phone's starting location and i have "text" displaying properly with no issues. It seems to be something with the fog specifically. The method i followed was the traditional local volumetric fog system with "exponential height fog" added to the scene with "volumetric fog" checkbox on. This is the only way to get this fog material and emitter to show up in the scene preview. Does AR require a different approach to this method?

      Comment

      Working...
      X