Announcement

Collapse
No announcement yet.

Unreal VR Build is running only at 60 fps why? But Runs at 80+FPS in editor(engine)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Unreal VR Build is running only at 60 fps why? But Runs at 80+FPS in editor(engine)

    I'm developing a VR game using the Unreal Engine. My target device is Oculus Rift and Rift S. According to the Oculus documentation, the VR application should run at 80-90FPS. But my application(build) is running at only 60fps. But the same project in the unreal editor (engine) is running at 80+ FPS. One thing I found is that when I removed my monitor connection, the Frame rate hits 80+ (Build). Why is this happening? I thought this might be due to some bad polycount mesh, heavy postprocessing or complex material. So this time I exported/packed the sample VR Template by Unreal Engine instead of testing my game. OMG! This build is also running at 59.1 FPS (a very basic unreal's default VR Template). I think there is something in the Unreal Engine side that caps the fps for the builds.

    System Spec:
    • Geforce GTX 1060 3GB | 16 GB RAM DDR3 | i7 9th gen 3.7Ghz Processor
    • Oculus Rift Headset Unreal Engine 4.23 Oculus Lost Frame tool and VRCValidator were used to test the FPS. I also tried with some other 3rd party fps measuring tools.

    Thanks in Advance!

    #2
    Disable smooth framerate in the project settings.

    Comment

    Working...
    X